Video Screencast Help

0xe0009578 - Unable to copy the virtual machine disk using the VMware VixDiskLib

Created: 18 Jun 2010 | 13 comments
ScottHastings's picture

Hi,

I use BackupExec 2010 with VMWare agent to backup a vSphere 4 serverfarm. On three servers I get the error message 0xe0009578 - Unable to copy the virtual machine disk using the VMware VixDiskLib. The KB articel linked to this error message mentions that this error occours when the VM has virtual harddisks on different datastores. This does not apply to all three affected VMs. In particular, one VM has only one virtual harddisk. Nevertheless, I applyed the suggested hotfix 348284 (that superseeded the previous hotfix 344584). But the error is still there.

Any ideas? LiveUpdate says, installation is up to date.

Regards

Comments 13 CommentsJump to latest comment

teiva-boy's picture

Call support and open up a case.  

Better yet due to long wait times on the phone, open a case from mysupport.symantec.com to save you the long hold times.  Symantec will call you

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

YvieD's picture

The first part of the message reads "Unable to copy the virtual machine disk using the VMware VixDiskLib" but what is after that?
The hotfix mentioned above was written to address the message " vixdisklib_read() reported the error: You have requested access to an area of the virtual disk that is out of bounds "
That specific error has been observed with virtual machine that have disks (VMDK)  mounted across multiple datastores.

However, if you are seeing something different, open a web case with support so that data can be collected and this issue can be addressed.

 

dgrove12's picture

I have this exact issue but only on one VM.  I'm backing up MANY others without issue using AVVI.  The media server is current on all hotfixes including the one that supposedly resolves this issue, 344584.   None of the disks are persistent for the VM.  Moving it to another ESX host didn't help.  Didn't svmotion to different storage, but again... I'm backing up other VMs on this datastore without any problems.

Anyone else have any ideas??

vickyinstru2000's picture

Even i am facing the same issue. But the funny part is that out of 5 VM i am backing up only one is giving this error and all other are backing up without any issue.Even my media server is upto date with all the available hotfixes so far. I have logged a case with Symantec but so far i have just submitted logsand waiting for further updates from Symantec.In my case the case has been escalated to Advanced Team.I hope this issue is fixed once and for all.
If at all anyone got the solution for this please let us know.
Thanks in advance.

I have attached snapshot of the error.

error.JPG

Regards,

Vikram Madhav Shinde

vickyinstru2000's picture

Why does it say that .vmdk file is corrupt even after i uncheck the verify option it says file cannot verify.
After consulting VMware he backed up these files using VCB mounter and it didnt give any errors and he told me to co-ordinate with SYmantec about this.

new error.JPG

Regards,

Vikram Madhav Shinde

vickyinstru2000's picture

Ppl any update on this one..is there anyone who is facing the same issue as i am???

Regards,

Vikram Madhav Shinde

Lawe's picture

Hello,
i user BE 2010 R2 an i have the same issue at one VM. I backup 120 Vm withou this Problem. The one VM which have this Error is a Windows VM. i've testet something without achievement.
Clone the VM -> same error
New VM with same vmdk -> same error
New Vm with new vmdk and Acronis Image -> same error

Regards,
Lawe

Allison Gibb's picture

Hi.   I am have the same error.  This particular server has been backing up fine for months and then two nights ago failed and then failed again last night. 

Any update?

Thanks

andreas.zeiler's picture

Having the same issue I opened a call at september, 13. Still under investigation.

This is the errormsg in german:

Endgültiger Fehler: 0xe0009578 - Der Datenträger des virtuellen Computers konnte mit VMware VixDiskLib nicht kopiert werden. Endgültige Fehlerkategorie: Ressourcenfehler Zusätzliche Informationen zu diesem Fehler finden Sie unter der Verknüpfung V-79-57344-38264

 

Regards, andi