Video Screencast Help

10.0.3 Issue after upgrade

Created: 17 Mar 2013 • Updated: 28 Feb 2015 | 7 comments
This issue has been solved. See solution.

Hi Guys, Thought i would throw this out here before logging with support.

I upgraded to 10.0.3 for Exchange a few days ago. Single server upgrade.  All went well, no errors or issues with the upgrade. All components upgraded successfully post-upgrade upon starting of the services. ie. DB, Index etc.

I then went to setup a new users Outlook-Addin and found there was no vaults allocated to the user. Thought maybe a provisioning issue so troubleshooted this but users was provisioned fine.

Checked my own Outlook which is using virtual vault with vault cache and for each item opened I get this error:

Enterprise Vault is unable to retrieve this archived item.
There was a problem opening this item. Try again later.

Did a full reset of my cache just to test and this didnt help. some problem.

Turned on full logging and noticed this:

17/03/2013 22:14:07.612[6244][L]: ~CInternetSendDataBase::ReadResponseHeaders
17/03/2013 22:14:07.613[6244][L]: CInternetSendDataBase::ReadResponseBody
17/03/2013 22:14:07.613[6244][M]: Body is <?xml version='1.0' encoding='utf-8'?></ListArchivesResponse></MDCSyncResponse>
17/03/2013 22:14:07.615[6244][L]: ~CInternetSendDataBase::ReadResponseBody
17/03/2013 22:14:07.615[6244][L]: StatusCode = 500

When trying to browser the http://vaultserver/EnterpriseVault/listarchvies.aspx I also get:

HTTP Status 500

Trying to launch the archive explorere in Outlook also generates the 500 error:

The xml returned for the tree view is not as expected. (500)

IIS logs 500 error also:

2013-03-18 00:24:24 GET /EnterpriseVault/TreeViewXML.asp version=1&state=1&archiveTypes=45 80 DOMAIN\USER Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+WOW64;+Trident/6.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+.NET4.0C;+.NET+CLR+1.1.4322;+InfoPath.3;+.NET4.0E;+Microsoft+Outlook+15.0.4420) 500 0 0 318

I downgraded the Outlook-addin for the new users back to 10.0.2 as I thought it might be a 10.0.3 bug but the same result.

Rebooted the server and the index service failed to load with this error in the event log:

An unexpected error has occurred.
Error Summary: Indexing Service start up error
Error Details: Index Admin child process EVIndexQueryServer failed to start within the timeout period
Reference: ServiceBaseEx::Run
Stack Trace:    at Symantec.EnterpriseVault.Indexing.Admin.ChildProcessManager.StartChildProcesses(IndexAdminService indexAdminservice)
   at KVS.EnterpriseVault.Common.ServiceBaseEx.ContinueOrAbortStartup(Action action)
   at Symantec.EnterpriseVault.Indexing.Admin.IndexAdminService.OnPerformStartup(Boolean HotRestart)
   at KVS.EnterpriseVault.Common.ServiceBaseEx.Run()

Manually starting the indexing service and it started fine with no errors so not sure if its related.

To me it seems like an IIS issue??? but not sure why!!!!

Anyone seen with this with 10.0.3 or can point me in the right direction?

Acutal user previsioning, email archiving, and tasks etc all seem to be working fine.



Operating Systems:

Comments 7 CommentsJump to latest comment

Calis's picture

Ok I managed to fix the it.

In IIS my ISAPI and CGI Restrictions filter looked like this:

Now I dont recall any specific ASP.NET v4 requirements being listed or requiring changes but I enabled the two listed 'Not Allowed', did an IISREST, and now it works.

I simulated it again and both times got the same result.

Now I cant tell you why this is set as it is or if the upgrade changed it because I didnt see it before the upgrade. I could roll back to a snapshot and check but wont risk it!!

Maybe I missed something in ALL that documentation????

I'll run all my tests again and report back.

JesusWept3's picture

Thats strange, V4 is definitely not a requirement, its even pending support in the compatibility charts, definitely not a requirement.

It sounds like the virtual directory got switched to net framework 4.0 possibly which would explain why it failed when it was set to not allowed

Calis's picture

thanks JW3, I though similar but the .NET version is set on the App Pool in IIS 7 and I can confirm all App Pools for EV are running under .NET v2.0.50727.

strange indeed.

JesusWept3's picture

So if you turn v4 off again, does it fail again??

JesusWept3's picture

That is bizarro!!!
Will play about tomorrow and see what I can see

Calis's picture

appriciated mate.

My enviroment was clean 10.0.2 install then single server upgrade to 10.0.3

I've never had to touch the IIS settings.

good luck! lol