Video Screencast Help

1041 Error Win7 64bit - $Altiris_Agent_Cache_Path$

Created: 17 May 2012 | 3 comments

Hello All,

We have an issue Importing and Activating layers on Win7 64bit. The altiris deployment will fail with error code 1041.  The install command is as follows

SVSCMD.exe e5badd88-c559-44cf-bcc6-63313052f2aa IMPORT -PATH "$Altiris_Agent_Cache_Path$\{b7ae5ec9-b340-4de8-8ba2-6d57775d5d26}\Cache\Internet Explorer 8.vsa" autoactivate -y

Now, this also fails if I run this command from a command prompt, even though the .VSA is located in the PATH.  However, if i change the $Altiris_Agent_Cache_Path$ to C:\Program Files (x86)\Altiris\Altiris Agent\Software Delivery\.... the vsa is imported correctly. 

Has anyone seen this issue before? I have seen a previous thread stating that it is not necessary to have the $Altiris_Agent_Cache_Path$ in the package, I'm not sure if that is correct and I've tried to change it in the Altiris Package but it reverts back to $Altiris_Agent_Cache_Path$\....

Any Advice would be appreciated.

 

Comments 3 CommentsJump to latest comment

AngelD's picture

If you have imported the package, deploying it as a software release then you should only need to specify the filename.vsa in the command line as the "cache" folder will be set as the working directory during command execution.

ex.

SVSCMD.exe e5badd88-c559-44cf-bcc6-63313052f2aa IMPORT -PATH "Internet Explorer 8.vsa" autoactivate -y

AngelD's picture

Oh and it should be "ACTIVATE AUTO -Y"

Wadders's picture

Thanks for the response AngelID.

The situation is that this is running from the Altiris Cache, so in the Altiris Package the $Altiris_Agent_Cache_Path$ is specified as a variable and that is where the problem lies, even though in the Altiris Agents it specifies the correct path.  If the $Altiris_Agent_Cache_Path$ is not entered bu the full path is then it works ok, so something is failing in the variable resolution.

 

Thanks

Wadders