Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

11d does not see device, device manager does

Created: 31 Jul 2009 • Updated: 21 May 2010 | 8 comments
OmahaMCSE's picture
This issue has been solved. See solution.

Please read carefully before replying. I took plenty of time to try many things before posting and took the time to type them in to tell you about them. Thanks.

Cusomer had a server die, no video no P.O.S.T after being shut down and moved. I pulled hot swap drives and put them in an almost exact duplicate machine, ML350 G4p. RAID controller pulled the config off the drives and it booted no problem, old server running on a new (different) server.

I then shut the server down and moved the tape drive over, an HP Ultrium 448, same SCSI id, same controller port as when it was in the old server. On board SCSI, not RAD controller. Brought server up, Windows sees the drive in device manager but devices in BE is empty except for an empty device pool.

BE 11.0 (11d) rev 6235 SP3 HF 35 & 38. Was at just the base install with no SPs of HFs.

RSM is disabled.

If I run the BE diagnostics and it sees there is a drive on the system:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[3200] 07/31/09 06:54:47.812 Device Discovery:

Scsi Address
Prt :Bus :Tar :Lun Attributes
------------------- -------------------------------------------------------------------------------

0005:0000:0003:0000 Device Name "\\.\Tape0"
Secondary Name "\\?\scsi#sequential&ven_hp&prod_ultrium_2-scsi&rev_s65d#5&50cb971&0&000300#{53f5630b-b6bf-11d0-94f2-00a0c91efb8b}"
Primary Inquiry "HP Ultrium 2-SCSI S65D"
Serial Number "HP Ultrium 2-SCSI HU10721VKU"
Device Flags KSCSI, SN(TYPE 1)
Device State 3, Online

Device IDs 1002, {8CC315CD-F193-466E-A45E-724B5AF9E673}
Device Name "HP 1"
Device Type 134283265, "LTO 64K (64K,10,0,E,HU)"
Device Features 0x000FFB7F: PB,SFB,SRB,WFM,SFF,SRM,PEOD,ES,EL,LU,E,SBS,DC,SDC,TA,HU,DR,RR
Device Element 0, 0

------------------- -------------------------------------------------------------------------------

[3200] 07/31/09 06:54:48.000 Start Rsm Support:

[3200] 07/31/09 06:54:48.015 Device Discovery End:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

I tried using HP drivers, Symantec drivers and it may have originally loaded MS drivers. I updated the drive's FW and have rebooted multiple times.

No unknowns in device manager.

Windows Backup saw the device fine.

The drive worked fine on the OS install, on this install of BE and now it doesn't on different but basically the same HW.

Is there a spot in the registry where BE holds onto known devices that needs to be cleaned out??

TIA for you time and thoughts.

-Joel

Comments 8 CommentsJump to latest comment

Ken Putnam's picture

Is there a spot in the registry where BE holds onto known devices that needs to be cleaned out??

Don't remember if is in v11 or not, but at one point you could run TAPEINST and tell it to remove all devices not found, then boot and run it again to (re)install devices in BackupExec

if the install does work after that, you may  need to edit your jobs to point to the new device name

If this response answers your concern, please mark it as a "solution"

OmahaMCSE's picture

Ken, Thanks for the fast reply.
Tapeinst seems to be the same thing as the device configuration wizard, gets to the same place and tapeinst is the process. Wording on the screen is a little different though.
I've used  the device config wizard before to remove Symantec drivers but just did it again with tapeinst.exe, but will need to wait until tonight to reboot.

I'll post back after rebooting.

-Joel

OmahaMCSE's picture

Nope, tapeinst just removes the veritas drivers.
After reboot tape drive is using HP drivers, still shown in device manager, still not showing in BE devices.

nia's picture

 Hi Joel,

Have you tried to uninstall the drives manually from the device manager and then run the Device wizard to install the Symantec Drivers?

Nikos Apostolou Systems Engineer

OmahaMCSE's picture

Nikos,
Interesting...
I uninstalled manually from device manager so the tape drive was gone alltogether, ran device config wizrd and got the error:
Installing Symantec "halfinch.sys" for "SCSI\SequentialHP______Ultrium_2-SCSI__S65D"
Driver load failure 0x800F020B for SCSI\SequentialHP______Ultrium_2-SCSI__S65D
The device instance does not exist in the hardware tree.
Installation is not complete.

Have not gotten this up until now when it was not in device manager first.

This did give me more to look for, and I found that I am not the only one in this boat.

First KB document I found 248405 looked promising but didn't work. BEDiag does not list a driver for IdeChnDr

Found other post saying to upgrade to build 7170, so I am downloading now. Will update.

BEsymc's picture

Please paste list of installed applications on this OS, over your reply. Check whether there is any application installed on this server, which also might be using tape drive. Also, stop and disable "Removable storage" service from the machine.

OmahaMCSE's picture

Thanks for your thoughts.
RSM is diabled as I had in my first post.
No software has changed between moving drives to new server.
There is no other backup software other than WIndows backup (which does not run with RSM disbaled) and BE.

-Joel

OmahaMCSE's picture

After upgrading to build 7170 and rebooting the ultrium drive was seen in devices and device manager shaowed it was using the Symantec drivers.

There must have been major issues with the 6235 build and how it handled devices..

Thanks to everyone for their input.

-Joel

SOLUTION