Video Screencast Help

12.1 SEPM will not do liveupdates

Created: 29 Jan 2013 | 14 comments

I know I must be missing something here. When I go to do liveupdates from SEPM it says "unexpected server error". I have the proxy set correctly. I did exactly as this doc said to http://www.symantec.com/business/support/index?page=content&id=TECH166923&profileURL=https%3A%2F%2Fsymaccount-profile.symantec.com%2FSSO%2Findex.jsp%3FssoID%3D1359475512428Wam8wO338F97vTPDIVS9q3Ma11O2ZP8jSokF1

and that said it was successful but SEPM says the old versions and continues to say unexected server error. I was able only to be successful when I first installed it in November. It is a 2008 R2 server.

Frustrating.

Comments 14 CommentsJump to latest comment

pete_4u2002's picture

can you post the error?
can you run dbvalidator and check if it passes?

Ashish-Sharma's picture

HI,

Can you post error screen shot or error code ?

Check this thread also may be help

https://www-secure.symantec.com/connect/forums/liveupdate-does-not-update-only-manually-through-sepm

Thanks In Advance

Ashish Sharma

 

 

.Brian's picture

What is the error code you're geting?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

SMLatCST's picture

Can you grab and post the log.liveupdate file from your SEPM and look for errors in there please?

Other suggested articles:

http://www.symantec.com/docs/TECH105924

http://www.symantec.com/docs/TECH95790

#EDIT#

And another:

http://www.symantec.com/docs/TECH185071

macpiano's picture

From end of the SEMS.log

01/29 10:42:28 [0e70:1308] INFO(Low)  spcIronS DefaultDefUtilsContentHandler CDefUtils::PostMicroDef25Update() - returning DU_S_OK (File = update.cpp, Line = 2260
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 SesmLu OnLuNotify(0x02, {C6A6D4AF-0AB4-F6D4-0039-BF121BF35C90}) -> PostSession callback invoked...
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 SesmLu PostSession callback...
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 SesmLu ---- PostSession Processing ----
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 AbstractLuContentHandler UpdateStatus: 'No this property'.
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 SesmLu Nothing downloaded (such as update cancelled, content unavailable or content up-to-date).
01/29 10:42:28 [0d54:0d18] INFO(Low)  spcAvClient32en_12_1 ProductUtil ConfProp: scm.http.port=9090
01/29 10:42:28 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 SesmLu http://127.0.0.1:9090/servlet/ConsoleServlet?ActionType=ConfigServer&ServerMoniker={C6A6D4AF-0AB4-F6D4-0039-BF121BF35C90}&action=LogContentUpToDate
01/29 10:42:29 [0d54:0d18] ERROR      spcAvClient32en_12_1 SesmLu InternetOpenUrl failedat .\SesmLu.cpp[1567]
01/29 10:42:29 [0d54:0d18] ERROR      spcAvClient32en_12_1 SesmLu Failed to notify server of up-to-date content.at .\SesmLu.cpp[1319]
01/29 10:42:29 [0d54:0d18] INFO(Med)  spcAvClient32en_12_1 PrePostSetupHandler Cleaning temp directories and reg keys
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 SesmLu OnLuNotify(0x02, {43EEFBAE-0AB4-F6D4-0039-BF120CC562DF}) -> PostSession callback invoked...
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 SesmLu PostSession callback...
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 SesmLu ---- PostSession Processing ----
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 AbstractLuContentHandler UpdateStatus: 'No this property'.
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 SesmLu Nothing downloaded (such as update cancelled, content unavailable or content up-to-date).
01/29 10:42:29 [0e0c:1200] INFO(Low)  spcAvClient64en_12_1 ProductUtil ConfProp: scm.http.port=9090
01/29 10:42:29 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 SesmLu http://127.0.0.1:9090/servlet/ConsoleServlet?ActionType=ConfigServer&ServerMoniker={43EEFBAE-0AB4-F6D4-0039-BF120CC562DF}&action=LogContentUpToDate
01/29 10:42:30 [0e0c:1200] ERROR      spcAvClient64en_12_1 SesmLu InternetOpenUrl failedat .\SesmLu.cpp[1567]
01/29 10:42:30 [0e0c:1200] ERROR      spcAvClient64en_12_1 SesmLu Failed to notify server of up-to-date content.at .\SesmLu.cpp[1319]
01/29 10:42:30 [0e0c:1200] INFO(Med)  spcAvClient64en_12_1 PrePostSetupHandler Cleaning temp directories and reg keys

macpiano's picture

I also get this in log.liveupdate

1/29/2013, 15:44:08 GMT -> Account launching LiveUpdate is not a logged in user's account

Is that the issue?

SMLatCST's picture

The sesmlu.log just seems to say "nothing downloaded" and says this could be because there was nothing new (among other reasons).

Please look through the log.liveupdate for any other errors.  I'd recommend focussing your efforts around about the last time you saw the unexpected error you mentioned.

The log entry about the account used not being logged in is not usually an issue.

macpiano's picture

I have looked through the log.liveupdate and it seemed fine the first couple days back in Nov.  but there are no obvious errors after that.

It has been a while since I set up a SEPM but I was thinking that the Windows 2008 R@ 64 bit server needed something configured to make the Liveupdate work correctly.

SMLatCST's picture

Nope, no special configuration options are required on Win2k8R2 for LiveUpdate to work.  It's only really the IE Enhanced Security bits that mess with SEPM, but that's more to do with it's ability to display the console.

Have you got a screenshot of the errors you're seeing?  I assumed you've verified none of my earlier linked articles apply?

SMLatCST's picture

Can you check the scm-server-0.log for any errors there too?  Also, perhaps consider posting the log.liveupdate if you'd like us to take a look at it smiley

Also, please try running a liveupdate ont eh SEPM manually (start -> Run -> luall) as this sometimes shows more detailed errors

macpiano's picture

The luall runs succesfully but doesn't show up in SEPM. Also SEPM from teh console just told me no updates were found for the virus definitions.

 Attached is the log.liveupdate

AttachmentSize
Log.txt 4.4 MB
SMLatCST's picture

Have you tried taking out the proxy and allowing the SEPM to connect to Symantec LiveUpdate directly?  The log is chock full of entries suggesting the proxy may be caching some content and thus preventing the SEPM from obtaining the latest files.