Video Screencast Help

2010 remote agent installation error

Created: 18 Mar 2010 | 7 comments

I get the following when trying to push out a remote agent with Backup Exec 2010

"Error connecting to the remote server.  Ensure that the server is available, has WMI enabled, and is not blocked by a firewall.24"

I have verified that WMI is working, there is no firewall blocking traffic and I can ping and remote into the server from the main box where the Backup Exec software is installed.  This is one of many virtualized servers on the network.  I could get the agent pushed out on other servers except for this one.  It had a previous remote agent installed on all the servers.  I was able to successfully detect and upgrade the others, however; I keep getting this error even after un-installing, rebooting, and trying to re-install the agent again.  Any ideas?

Comments 7 CommentsJump to latest comment

Mike Serbin's picture

I am having the same issue.  I have 2 Windows 2003 Standard servers running virtually on ESXi.  The remote agent push install worked fine on one and not the other.  I am using the same domain admin account for both installs so I don't think it is related to user permissions.  A definite work around is to do a local install of the agent on the server by downloading the BE install media and installing the agent that way.  I would like to eventually figure out why it isn't allowing me to do the push installation.

Dev T's picture

Hello,

The best way would be installing remote agent in Silent Mode.

For 32-bit remote servers
1  : Copy the RAWS32 and MSXML folders from the Backup Exec Server in a new folder on the Remote Server (C:\prog. files\symantec\backup exec\agents\RAWS32 and MSXML)
2  : On the Remote server, open command prompt and navigate to the RAWS32 folder and run setupaa.cmd
Example : D:\BEAGENT\RAWS32\>setupaa.cmd
3  : Go to Start-->All Prog-->Symantec-->Remote Agent Utility
4  : Click on the Publishing TAB, enable Publiching and ADD the NAME OR the IP Address of the BE Server, Restart the Remote Agent Service on the Remote Server

This will install the Remote Agent in Silent Mode

For 64-bit Remote Server:
1  : Copy the RAWSx64 folder insteed of RAWS32 and run setupex64.cmd insteed of setupaa.cmd and follow the steps above

Hope this helps.....

Its a best practice to have a "Support Contract" with Symantec...
 

RahulG's picture

Installing the remote agent is a workaround and would save your time .
Incase if you would like to troubleshoot further there Special considerations for installing Backup Exec to remote computers
Item
Consideration

Windows XP SP2/Server 2003 SP1
To push-install Backup Exec to a Windows XP SP2/Server 2003 computer, you must enable File and Printer Sharing on the Windows Firewall Exceptions list for the following ports:
135 (RPC)
445 (TCP)
103X (mostly 1037)
441 (RPC)
For more information about the Windows Firewall Exceptions list, refer to your Microsoft Windows documentation.
During the installation process, Backup Exec sets the Remote Launch and Remote Access security permissions for the Administrator’s group.
You should enable the "Allow remote administration exception" group policy for the computer to which you push the installation.

Windows Server 2008
To push-install Backup Exec to a computer that runs Windows Server 2008, you must enable certain items on the destination computer’s Windows Firewall Exceptions list. You must enable the following items:
File and Printer Sharing
Windows Management Instrumentation (WMI)
For more information refer to your Microsoft Windows documentation.

RahulG's picture

Also you can try the following Microsoft solution:
WMI Remote execution requires the following:
For Local Group / Local Computer Policy
Computer Configuration/Windows Settings/Security Settings/Local Policies/User Rights Assignments
Administrators, Local Service, and Network Service accounts have the right "Adjust Memory Quotas for Process Properties"
Local Service, and Network Service have the "Replace a process level token"
Remote User is a member of the local Administrators Group
Remote registry is enabled.
WMI enabled and remote request to create process should be accepted by the server
Verify using "gpedit.msc" console the the above rights.
If the right for "Local Service" and "Network Service" services don't have the right "Replace a process level token" within local computer policy, run the following commands
Can use the following command to apply these rights
ntrights -u "Local Service" -m \\server1 +r SeAssignPrimaryTokenPrivilege
ntrights -u "Network Service" -m \\server1 +r SeAssignPrimaryTokenPrivilege

(Note: Install Windows 2003 Resource Kit for the ntrights.exe application.
The above right was not applied to Newly installed Servers built with Windows 2003SP1 or later.)

Update group policy (GPUPDATE /Force). A reboot may be needed.

Symanticus's picture

Hi All,

I also facing the same problem here, my both domain controller and exchange server 2007 installed on Win2k3 x64 and all of them failed to install
"Error connecting to the remote server.  Ensure that the server is available, has WMI enabled, and is not blocked by a firewall.24"

but if i select another Windows Server 2003 x64 system with no RAWS install, it went fine ?!?!

only those two (DC and ExcSrv2007) are still running with the old BE 12.5 agent RAWS, which one is the solution for this problem please ?

/* Infrastructure Support Engineer */

colval's picture

I ajusted the two parameter : "Adjust Memory Quotas for Process Properties" and "Replace a process level token"
Reboot the server

Now I am able to install my remote agent.

Thank you

s.hasslinger's picture

Hi,

i ajusted the policies
-Adjust Memory Quotas for Process Properties
-Replace a process level token

in a new group policy rolled out to the Backup Servers.

On German Server called:
-Anpassen von Speicherkontingenten für einen Prozess
-Ersetzen eines Tokens auf Prozessebene

-> make a gpudate /force

It Works fine since the changes, Thank You!