Video Screencast Help

2012 Hyper-V Guests not showing in server list

Created: 14 Oct 2013 • Updated: 17 Oct 2013 | 8 comments
This issue has been solved. See solution.

Hello,

I have just taken over the backup of a couple of Hyper-V servers in our environment running Server 2008R2 VMs. One of these is a sharepoint 2010 server for light usage the others are a mix of standard file servers and application servers.

SBE 2012 is installed on one of the VM hosts [V-Host1].

SBE RAWs agent is installed on the second [V-Host2]

I've been going over the backups and would like to institute a more granular restore option for our servers.

My Jobs consist of the following:

For V-Host1 I have a simple single server backup with the VMs selected from the available node.

For V-Host2, again, a simple backup with the VMs selected in the appropriate node.

For Sharepoint - Sharepoint agent installed and running farm backup.

The issue:

I am unable to restore individual files from any of the VMs on V-Host1. There is no option as the servers do not show up in the server list.

However, the Guests on V-Host2 are showing up in the Server List in Backup and Restore tab. They are demarked as Windows Computer (Virtual Machine) with a blue icon. I can perform file restorations from these without issue. I believe this is how they're supposed to appear and I do not recall doing anything special to make them appear in this list.

How do I get the VMs from V-Host1 to show up in the server list as VMs so that the data backed up in the V-Host1 backup can be restored on a file basis?

 

Operating Systems:

Comments 8 CommentsJump to latest comment

CraigV's picture

...is the RAWS agent installed on the host, and have you installed the RAWS agents on the servers hosted on V-Host1?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Balthaer's picture

V-Host1 is the Media server. Do I need to install the RAWs as well?

I tried doing a push install to the VMs from the Media server but they show up as physical servers not as virtual machines and I also cannot perform GRT restores - they show up but the restore option is greyed out.

Do I need to run a backup from the V-Host1 job for the restore option to then show up on the VM server listed in the Servers list?

 

 

Jaydeep S's picture

Have you installed RAWS on all the VMs on Host 1 (Media Server). Once you do that and perform a backup, you should be able to view the VMs in the Backup / Restore tab for restoration.

SOLUTION
Balthaer's picture

The VMs are showing up now after a full backup.I have not attempted an GRT restore, however, as they're showing as completed with exceptions.:

Resource VRTSRV::\\V-Host1\Hyper-V?Store\Initial Store was not found in the previous instance of this job. It will be fully protected in this job.

Which I presume is nothing to worry about.

Backup- VRTSRV::\\V-Host1\Hyper-V?Virtual?Machine\vSR32
V-79-57344-38726 - Backup Exec failed to connect to virtual machine 'vSR32' and was unable to collect the necessary metadata to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup. You must install the Agent for Windows and the virtual machine tools provided by your host software on the virtual machine.

This one seems fairly straightforward and I just need to install the RAWs agent on the VM. However, if I push the install is BE2012 going to add it as a physical server? Would I be better off performing the install manually and establishing the trust?

Backup- VRTSRV::\\V-Host1\Hyper-V?Virtual?Machine\vSR25
V-79-57344-38732 - Virtual machine 'vSR25' does not meet the requirements necessary for Backup Exec to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup.

This is most likely the lack of RAWs and some SQL data which I probably need to use an agent to back up as a separate entity in the servers list.

V-79-57344-38725 - One or more virtual disks contain volumes that do not support Granular Recovery Technology (GRT). Granular restores cannot be performed for these volumes.

Not sure about this one. Where would I check what it's trying to back up in this instance?

Jaydeep S's picture

As a first step install RAWS on the VMs. This could help you eliminate a few errors. Another thing to note is, if you want to backup a VM which has SQL installed, you need to have a valid licence to do it installed on the Media server. This is applicable even for the GRT backup of a VM. For the last error about volumes not being supported, does the VM have any Dynamic disk or any vhd that reside on a NAS.

pkh's picture

When you say SBE, do you mean that you are using the Small Business edition of BE?  If so, then you can only backup one VM host.  The SB edition comes only one Hyper-V licence.  In this case, I don't know how you are going to backup the VM's on your other host.  If you want to back them up as physical machines, you can only add 2 more RAWS licences to the SB edition.

Balthaer's picture

No, sorry for the confusion. I meant symantec backup exec.

pkh's picture

If you want to back these VM's as VM's, then you need to backup the entire host including the VHD's.

There are some reports previous about situations like yours whereby the VM does not show up in the server list after a VM backup.  The trick to get to show up is to back up these VM as if they are physical servers.  This is a one-time thing and the VM backups will show up.