Video Screencast Help

5220 Appliance Master as FT Media Server

Created: 19 Apr 2013 | 7 comments
KeirL's picture

Hi

I undertsand that using a Master server as a FT media server is not recommended but I was interested to know if it is coded not to be configurable on a 5220 in that manner?

I have a two 5220 appliances - one is a Master\Media server and the other is a media server only (within a different NBU domain). I've set both appliances as FT media servers - that worked fine. But only the 5220 that is a media server works with a SAN client I have configured. The 5220 Master\Media server gives me an error (EMM Invalid ID) when I try to add the SAN client manually  - btw the SAN Client registered automatically on the other 5220.

Is this likely to be by design or an error that I can troubleshoot?

Both Appliances are running 2.5.2

many thanks 

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

KeirL's picture

Hi

Just a simple question to help me with this one....

Is anyone running a 5220 with 2.5.2 that is configured as a Master server and successfully backing up SAN Clients directly to the Apliance Master server?

kind regards

Mark_Solutions's picture

Are you using the same fibre port on both appiances?

It usually only sets the one port to FT mode when you enable fibre transport on an appliance so make sure you use the same one on both appiances

I dont remember anything about a Master Appliance not being able to do it - and in my training I seem to remember it was a Master appliance used for just that (if i remember correctly)

I haven't actually done it myself though on a Master but haven't seen anything in the Appliance guides to say that you cannot

Hope this helps?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

KeirL's picture

Thanks Mark

When I run the FC show I can see both ports have been set to 'Target' and these are the ones I have zoned to the SAN client ports. But the client didn't self register and when I try to add it manually I get an EMM database error saying it was an invalid ID..... which I guess is that NetBackup cannpt detect\communicate with the SAN client.

I have double checked the zoning but will check again, but basically zoned 1 port on the client to one of the target ports on the Appliance and the other port on the client to the second port on the Appliance (these are on dual fabrics).

When I couldn't get this to work and so tried it on the other Appliance (the one just configured as a media server), I simply changed the zones to remove the Master Appliance target ports and add the Media server target ports..... The (same) SAN client  registered straight away and backups worked over the fabric first time - Happy days!

Both appliances are exactly the same (firmware, etc) with the exception that one is running the Master server role as well as being a media server.....

I thing that has just struck me..... is that the SAN client I'm working with was already a SAN client within the NetBackup Domain that has the Media server Applince in it - it was working to a different media server before (non appliance).... so in affect I'm just moving this to a different media server (the 5220 appliance).

NetBackup was fully uninstalled on the SAN client and re-installed from scratch prior to trying to register it with the Master Appliance, but could there be something left over in the registry that still exists saying that it is already registered with a different NetBackup Domain and therefore will not re-register to a new Master server?? - just clutching really.....

Mark_Solutions's picture

FT used to just enable Slot 2 Port 1 on the Appliances - that is the one as you look at the back that is to the left hand side and  the lower card - below 4 x 1g ethernet ports and port 1 is the left hand one of the two.

Also Slot 4 Port 1 may be enabled - this is the one to the right, middle card immediately above the SAS expansion card - Port 1 is the port on the right this time.

So you need one or both of these ports zoning to the client

Do you use a capacity license - you do also need the licenses for SAN Client on the Master Server to use the feature.

Hope this helps

 

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Andrew Madsen's picture

The hint is the "the other is a media server only (within a different NBU domain)" statement you made. In the bp.conf of the client change the first SERVER = statement to the name of the 5220 Master/ Media combo. Then you shold work over FT with the Master / Media combo and not the Media alone. If that does not work post your bp.conf.

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.

KeirL's picture

Thanks both

I think the main thing I wanted to establish was if it should work  - which I now feel is defintiely the case. I'm happy to go over everything with a fine toothed comb now that I know I'm not wasting my time and effort.

It'll be a coupe of weeks before I get another chance to move this SAN client over to the Master\Media Appliance to retest, but will let you know what I find.

btw - the SAN client is a Windows server and was configued for the Master\Media combo when the NBU client software was re-installed. However, I didn't try doing any standard LAN backups prior to configuring the SAN client connectivity so that may be a worthwhile step just to prove communication functionality when I next get a chance to play with it.

 

thanks again

Mark_Solutions's picture

Good stuff - do remember to let us know how you get on

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.