Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

5220 replication speed throttling

Created: 22 Jul 2012 | 4 comments
Kenneth Hansen's picture

Hi,

I have a problem with two 5220 replication data over WAN link. When replication kicks in it consumes all WAN link speed and this causes problem related to other traffic on the link. Appliance's uses 2.5 software.

I've tryed thees setting without any sueccess:

OptDupBandwidth     The maximum bandwidth that is allowed for optimized duplication.
Main_Menu> Settings> Deduplication>tune OptDupBandwidth Value Bandwidth in KBs/sec

And

BandwidthLimit      The maximum bandwidth that is allowed when backing up or restoring data between the media server and the deduplication pool.
Main_Menu> Settings> Deduplication>tune BandwidthLimit Limit   Bandwidth limit in KBytes/second.

I also looked at:
http://news.support.veritas.com/connect/forums/thr...
http://www.symantec.com/connect/forums/duplication...

But had no success, any one know if it is possible to limit bandwith use for replication?

Comments 4 CommentsJump to latest comment

chashock's picture

Just so I understand what's going on, you're using an SLP to replicate from one 5220 to another 5220, both running 2.5, yes?

Can you post the Main_Menu>Settings>Deduplication>show output?

Kenneth Hansen's picture

Yes, you are correct. SLP to replicate from one 5220 to another 5220..

chashock's picture

How much "room" do you have on your pipe?  If I remember the optdup_bandwidth tuning correctly, it's set in kilobytes per second, which translates to 54 megabits per second.  If you only have enoug capacity to transmit at 20Mb/s you're still going to run into issues since the appliance doesn't know that and will pump data out up to the limit you've set.

Have you tried other settings (lower numbers) with the same results of your link being hammered?

Mark_Solutions's picture

I believe that there is a formula to follow here whichhelp you decide what the OPTDUP_BANDWIDTH needs to be ...

You need to know the maximum number of streams that can run (this is actually 4 by default - in the pd.conf i believe), the max number of jobs (based on the Storage Unit(s) setting),

So here goes ...

(maxstreams x max jobs x optdupsetting x 8)/1024 = bandwidth used

So if you storage units can do 50 jobs max and you set the optdup setting to 7000 it will use:

(4 x 50 x 7000 x 8)/1024 = 10937 kb/s

So it can use 10937 kb/s rather than the 7000 kb/s you are probably expecting! (don't shoot the messenger - just trying to help!)

Put you STU max jobs in and see what you get then reduce the optdup value until the result is what you really want and try again

Hope this makes sense and helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.