Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

7.5 Agent cleanup on NS

Created: 07 Apr 2014 • Updated: 09 Apr 2014 | 19 comments
This issue has been solved. See solution.

After upgrading from 7.1.x to 7.5 on Friday, I checked the Agents installed on the Notification Server and saw some discrepancies that I'm not sure how to fix.  I marked them in red below. 

Untitled.png

Perhaps some of these are installed on the NS when they shouldn't be?

Thanks for any advice!

Operating Systems:

Comments 19 CommentsJump to latest comment

Igor Perevozchikov's picture

Hi,

seems like these rollout policies are enabled and your NS server is automatically included in resource target of "Monitor Agent x64" and "Inventory Agent" rollout policies (Don't know why NS is automatically included in "Deployment Agent" rollout policy, since it should be excluded from there).

Please make sure what rollout policies you have there enabled (probably there are some cloned, etc..) and check what resource targets are there:

RolloutPolicies.jpg

You can clone separate "Uninstall" rollout policy for "DS plugin x64", "Monitor Agent x64" and "Inventory Agent", including only your NS server in resource target, then these plug-ins will be uninstalled for local NS server.

Also you will need to exclude your NS server from default resource targets of "DS plug-in x64", "Monitor Agent x64" and "Inventory Agent" install rollout policies, to avoid further installation of them on NS server.

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

Thank you for your response, Igor.  One question though... I don't see any settings for the Monitor Agent in the SMC to allow me to uninstall that agent, so how would I go about uninstalling that plugin?  This is all I have:

MA.JPG

Thanks!

Igor Perevozchikov's picture

You can browse all available rollout policies in SMP:

  • Open SMC ⇒ navigate to "Actions" ⇒ naviga
  • te to "Agents/Plug-ins" ⇒ click on rollout "Agents/Plug-ins"
  • There you will see "Monitoring and Alerting" folder where are stored all monitor agent-based plug-ins rollout policies.

AgentUninstall_2.jpg

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

So, despite having ONLY an uninstall task for the Deployment Plug-in and confirming that the only client in the filter is my desired target (the NS Server), a day later and a couple reboots for other things and the Deployment Solution Plug-In 7.1.7858 is still there.  The others have been cleaned up successfully.  Thoughts as to how I can force remove that plugin?

I see multiple "Update Client Configuration" tasks in the SMA Task History on the target.

Igor Perevozchikov's picture

⇒ Clone "Deployment Plug-in for Windows (x64) - Uninstall" rollout policy

⇒ set name like "Deployment Plug-in for Windows (x64) only for local NS Server - Uninstall"

⇒ delete default resource target from this cloned DS uninstall policy

⇒ add new resource target, which includes only local NS server ⇒ Save Changes

⇒ Refresh policies on NS Server

⇒ DS plugin uninstallation policy should be delivered to NS server and DS pluging should be uninstalled without any reboot.

Note:
I don't know why your local NS server has DS plug-in installed, since default resource target of DS plug-in rollout policy, should not include NS Servers. Make sure that resource target of "Deployment Plug-in for Windows (x64) - Install" rollout policy doesn't contain local NS Server.

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

Agreed... not sure why it's there, which is why I'm intent on removing it.  :)

I did everything you mentioned above based on your prior suggestion.  Still it remains.

DS7.1.JPG

Igor Perevozchikov's picture

Well, try to manually uninstall it.

  • On NS server, open this directory \\localhost\NSCap\bin\Win64\X64\Deployment\Agent\
  • There will be "Symantec_DeploymentSolutionAgent_7_5_x64.msi" package
  • Copy it, for example on C:\ drive
  • Open CMD and execute this command to uninstall DS plugin:

msiexec.exe /qn REBOOT=ReallySuppress skipaim=1 /x"C:\Symantec_DeploymentSolutionAgent_7_5_x64.msi"

  • Delete "Symantec_DeploymentSolutionAgent_7_5_x64.msi" from C:\ drive.
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

No change, so I removed the /qn to see what's up and...

DSerror.JPG

So this is probably why the uninstall task isn't working either... assuming it calls that .msi. 

I found a copy of Altiris_DeploymentSolutionAgent_7_1_x64.msi here:  C:\Program Files\Altiris\Altiris Agent\Package Delivery\{GUID}\cache\ and ran the uninstall for that.  However, even though the uninstall went through fine, the plugin is still showing and the listed .dll is still there.  I confirmed that I can delete the .dll without issue, so it may now just be the SMA that needs told what's up.  Thoughts?

Igor Perevozchikov's picture

Maybe you can try to upgrade this DS 7.1 plug-in to 7.5 version and after that perform manual uninstall of it via msiexec from cmd?

  • Or then unregister DS 7.1 .dlls from C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\
  • Also clear registry entries for DS 7.1 plug-in [HKEY_LOCAL_MACHINE]\SOFTWARE\Altiris\Altiris Agent\Deployment
  • Restart Altiris Agent
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SOLUTION
SaintFrag's picture

K, I think you're on to something.  First, the registry path you pointed to is non-existant, though I found this one:

HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Altiris Agent\Plugin Objects\Agents\Deployment Solution Base Agent

which has the 7.1 Deployment Solution Agent listed.  However, after deleting that and restarting the Altiris Agent, there was no change.

As for the upgrade idea, I had the default upgrade task in place with the default 'Applied to'.  I cloned and targeted my NS server explicitly.  Boom... the Agent version upgraded to 7.5.1602.  I tried to get the uninstall agent task to pick up, but after it did not, I manually uninstalled via the aforementioned .msi and... success!

Thank you for your assistance, it's greatly appreciated.

Igor Perevozchikov's picture

You're welcome :)

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

One final note for cleanup, seen in the Log Viewer:

Object 'Altiris.DeploymentSolutionAgent' is not installed: Invalid class string (0x800401F3). This situation should be resolved once the agent rollout has been completed.

-----------------------------------------------------------------------------------------------------

Date: 4/10/2014 12:25:13 PM, Tick Count: 400265, Host Name: WDSALTIRIS, Size: 391 B

Process: AeXNSAgent.exe (3832), Thread ID: 5732, Module: AeXNSAgent.exe

Priority: 2, Source: Agent

File: C:\ProgramData\Symantec\Symantec Agent\Logs\Agent.log

Any idea how to clean that one up?  :)

Igor Perevozchikov's picture

This is a similar problem with solution for CTA http://www.symantec.com/docs/TECH38148

Also make sure that there is no DS-plug-in .dll in installdir of DS plug-in (which was uninstalled) and registry records are removed for Deployment Solution plug-in.

And probably need to make sure that your NS Server isn't included in DS-plugin policies.

This can be checked in "Resource Manager" of your NS Server

  • Mouse right click menu on NS Server  ⇒ Open "Resource Manager" ⇒ Summaries ⇒ Policy Summary
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

Things got ugly.

ohno.JPG

Not sure if that screen cap will come through clear.  The major issue now is:

Error loading Deployment TaskServer Handler info: Error loading version resource: The system cannot find the file specified. (-2147024894)

-----------------------------------------------------------------------------------------------------

Date: 4/11/2014 3:31:02 PM, Tick Count: 6800031, Host Name: WDSALTIRIS, Size: 369 B

Process: AeXNSAgent.exe (2884), Thread ID: 3780, Module: AeXNSAgent.exe

Priority: 2, Source: AgentRegistrar

File: C:\ProgramData\Symantec\Symantec Agent\Logs\Agent.log

Igor Perevozchikov's picture

Maybe you can try to upgrade/reinstall this DS Task Server?

DS_Plugins_Upgrade.jpg

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

Well, you may be on to something with that one.  Except my server is listed under 'requiring Deployment Taks Server Component installed' yet sat there all weekend without doing so.  Looks like I've created some major issues by trying to remove the Deployment solution plugin.

Do you think a repair through SIM would fix my issues?

Igor Perevozchikov's picture

I don't think so, that SIM repair will fix this problem, because this happens for DS TaskServer plug-in on local SMA on NS Server, and SIM will do a repair just to reconfigure of product on Server Side.

As far as I know, Deployment Solution agent shouldn't be installed on local NS server and only DS task Server plug-in should be installed in case if Package Server is installed on local NS server.

Did you try to update/reinstall DS TaskServer plug-in? Any success?

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
SaintFrag's picture

After the previous post, I found this article.

Ran the batch file and it went through successfully.

Preliminary results (10 minutes) show clients are now registering correctly and many of the other errors are gone.  I currently have one remaining error:


Exception removing socket watch: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

at System.ThrowHelper.ThrowKeyNotFoundException()

at System.Collections.Generic.Dictionary`2.get_Item(TKey key)

at Altiris.DotNetLib.Sockets.SocketWatchThread.RemoveWatch(Int32 hc)

at Altiris.DotNetLib.Sockets.SocketWatch.RemoveWatch(Socket socket)

-----------------------------------------------------------------------------------------------------

Date: 4/14/2014 9:16:42 AM, Tick Count: 234434343, Host Name: WDSALTIRIS, Size: 646 B

Process: AtrsHost (3296), Thread ID: 68, Module: AtrsHost.exe

Priority: 1, Source: Altiris.DotNetLib.Sockets.SocketWatch.RemoveWatch

File: C:\ProgramData\Symantec\SMP\Logs\a.log
SaintFrag's picture

Weird... I don't have that, hence my confusion.  But I found an uninstall in this directory:  C:\Program Files\Altiris\Altiris Agent\x64\Monitor Agent

Ran that uninstall and the 7.1 agent is now gone.  :)

NoMA.JPG

Thanks.

SOLUTION