Video Screencast Help

(96) unable to allocate new media for backup, storage unit has none available

Created: 27 Aug 2013 • Updated: 27 Aug 2013 | 10 comments
sheriff_e47's picture
This issue has been solved. See solution.

Hi All,

 

I got this message detail:

Error nbjm (pid=10797) NBU status: 96, EMM status: No media is available
unable to allocate new media for backup, storage unit has none available  (96)
 
I've checked the scratch pool, there are still some medias (robot type: TLD) in this volume pool. 
 
I've tried to make a new volume pool too to be assigned at the policy
 
But, still, the backup got error 96. So, can anybody help me please. Thankyou
 
Note: 
This is Solaris 10 OS, NBU client 6.5, NBU Master 7.0, NBU Media server 7.0 
 
Operating Systems:

Comments 10 CommentsJump to latest comment

revaroo's picture

What about the policy, what storage unit is it using?

These tapes are all for TLD(0) and hcart2.

 

Lets see output of bppllist <policyname> -U

 

sheriff_e47's picture

Here;s the outpout:

bash-3.00# cd /usr/openv/netbackup/bin/admincmd/
bash-3.00# bppllist idesec_sap_offline -U
------------------------------------------------------------
 
Policy Name:       idesec_sap_offline
 
  Policy Type:         Standard
  Active:              yes
  Effective date:      03/12/2008 15:44:31
  Client Compress:     no
  Follow NFS Mounts:   no
  Cross Mount Points:  no
  Collect TIR info:    no
  Block Incremental:   no
  Mult. Data Streams:  no
  Client Encrypt:      no
  Checkpoint:          no
  Policy Priority:     0
  Max Jobs/Policy:     Unlimited
  Disaster Recovery:   0
  Collect BMR info:    no
  Residence:           mysides-hcart-robot-tld-0
  Volume Pool:         Idesec_off
  Server Group:        *ANY*
  Keyword:             (none specified)
  Data Classification:       -
  Residence is Storage Lifecycle Policy:    no
 
Granular Restore Info:  no
Ignore Client Direct:  no
  HW/OS/Client:  Solaris       Solaris10     idesec
 
  Include:  /usr/sap/PID
            /sapmnt/PID
            /usr/sap/trans
            /oracle
            /oracle/PID/origlogA
            /oracle/PID/mirrlogB
            /oracle/PID/sapreorg
            /oracle/PID/102_64
            /oracle/PID/origlogB
            /oracle/PID/mirrlogA
            /oracle/PID/oraarch
            /oracle/PID
 
  Schedule:          idesec_sap_off_sched
    Type:            Full Backup
    Maximum MPX:     1
    Synthetic:       0
    PFI Recovery:    0
    Retention Level: 3 (1 month)
    Number Copies:   1
    Fail on Error:   0
    Residence:       (specific storage unit not required)
    Volume Pool:     (same as policy volume pool)
    Server Group:    (same as specified for policy)
    Calendar sched: Enabled
      SPECIFIC DATE 0 - 01/18/2011
      Saturday, Week 1
      Saturday, Week 2
      Saturday, Week 3
      Saturday, Week 4
      Saturday, Week 5
    Residence is Storage Lifecycle Policy:     0
    Daily Windows:
          Saturday   01:00:00  -->  Saturday   03:00:00
 
bash-3.00# 
revaroo's picture

ok let's look at the output of 

 

bpstulist -label mysides-hcart-robot-tld-0 -U

sheriff_e47's picture

Here:

bash-3.00# bpstulist -label mysides-hcart-robot-tld-0 -U
 
Label:                mysides-hcart-robot-tld-0
Storage Unit Type:    Media Manager
Host Connection:      mysides
Number of Drives:     1
On Demand Only:       no
Max MPX/drive:        1
Density:              hcart - 1/2 Inch Cartridge
Robot Type/Number:    TLD / 0
Max Fragment Size:    1048576 MB
bash-3.00# 
 
 
sheriff_e47's picture

Hi, Revaroo

what do you think seems to be a problem? Pls advice.

revaroo's picture

Your tapes are set as hcart2, your storage unit is hcart - hence it requires hcart type tapes of which you have none in scratch. Change the the type for the tapes to hcart and it will work.

sheriff_e47's picture

Hi, Revaroo

 

I've change the media type to HCART and run the backup. But now it got error:

Error nbjm (pid=10797) NBU status: 2001, EMM status: No drives are available
No drives are available for this job  (2001)
 
 
So, can you please help me with this. Please your advice. Thankyou
 
revaroo's picture

So do you have any drives configured that are hcart? Perhaps your storage unit was wrong and the drives are actually hcart2

The backup see you have hcart storgage unit, reserves the tapes, then goes to reserve a drive - oh! we have none available that are hcart!

Let's see the output of tpconfig -d on the media server "mysides"  (tpconfig is located in volmgr/bin)

 

 

SOLUTION
sheriff_e47's picture

Hi, Revaroo

Yeah, i have checked the storage unit and it's turn out wrong. So, I changed it to HCART2 instead the media or the drive. Now, the backup can run normally. Thank you very much for your help.  

revaroo's picture

Sheriff, excellent, It was one of the 3 combinations (drive type, tape type or storage unit type).

 

Glad to be of help :)