Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Active Directory Import Rules fail to run on SMP 7.1 SP2

Created: 08 Jan 2013 • Updated: 14 Jan 2013 | 2 comments
This issue has been solved. See solution.

I noticed some of my AD import rules are no longer running like they were a couple days ago. Instead of displaying the green check mark, it displays a red x. I checked the log viewer and see the log below. I don't believe it's an Active Directory issue as the same import rules are setup on my test environment and those run successful. Has anyone seen this before?

Process: AeXSvc (1352)
Thread ID: 1594
Module: AeXSVC.exe
Source: Altiris.DirectoryServices.DirectoryImport.DirectoryDataProcessor.WriteResourceInventoryData
Description: While writing resource inventory for rule Import User resources from DOMAIN.com, from AD Group1/AD Group2/AD Group3 and using the default column mappings and these resource associations (GUID) System.InvalidOperationException caught in WriteResourceInventoryData. Reason: Directory data delivery failed in 5 attempts.

( Exception Details: System.InvalidOperationException: Directory data delivery failed in 5 attempts.
   at Altiris.DirectoryServices.DirectoryImport.NSMessageGenerator.RetriedRouterDelivery(String fileName, Int32 retries, Int32 sleepSeconds)
   at Altiris.DirectoryServices.DirectoryImport.NSMessageGenerator.GenerateAndSendNSMessage()
   at Altiris.DirectoryServices.DirectoryImport.DirectoryDataProcessor.WriteResourceInventoryData() )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.DirectoryServices.DirectoryImport.DirectoryDataProcessor.WriteResourceInventoryData()
   at Altiris.DirectoryServices.DirectoryImport.DirectoryDataProcessor.ProcessDirectoryData()
   at Altiris.DirectoryServices.DirectoryImport.ExportEventHandler.DataAvailableHandler(Object sender, DirectoryExporterDataArgs e)
   at Altiris.DirectoryServices.DirectoryExport.LDAPExporterThread.RaiseOnDataAvailable(EventNotifier eventNotifier, String exportId, DirectoryElementCollection dirElements)
   at Altiris.DirectoryServices.DirectoryExport.LDAPExporterThread.RaiseEvent(Boolean forced)
   at Altiris.DirectoryServices.DirectoryExport.LDAPExporterThread.GetDirectoryDataFromGroups()
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=System.InvalidOperationException Src=Altiris.DirectoryServices )

Comments 2 CommentsJump to latest comment

Stephan Rissac's picture

HI,

Have you tried to recreate the import rule ?

Regards

Stephan RISSAC

Symantec Technical Specialist For AZERYS a Symantec Platinum Partner based in France

JASYM2012's picture

Yes, I have tried to recreate the import rule and same issue.

I reviewed the Altiris logs further and noticed alot of "Queue was full" warnings. Got this article from Symantec support to modify eventqueue threshold settings and this seemed to resolve my issue. Thanks for responding.

 http://www.symantec.com/docs/TECH183347

SOLUTION