Video Screencast Help

Active Directory Users and Computers

Created: 20 Feb 2013 | 14 comments

All

I just did a test restore of the backup from my Primary Active Directory Domain Controller/DNS system, on a system running Windows Server 2003,and although everything on the desktop and in the C: drive is there, in Active Directory Users and Computers, none of the OUs I have are there. I backup everything on the computer, which only has a C: drive. Why have not the OUs been restored?

 

Thanks

Stephen Keating

 

Operating Systems:

Comments 14 CommentsJump to latest comment

Gurvinder Rait's picture

Did you also restore the System State ?

Stephen Keating's picture

I have noticed that the GPO owners are just letter number strings, as if the Enterprise and Domain Admins were some how stripped out during the restore to the new test DC. I blieve maybe this has soemthing to do with the OU containers being not there, as the ones created by the Domain Admins are not there, but the Default containers are. Is there something that must be done during the Restore process that prevents the Admin permissions being changed? 

AshutoshTamhankar's picture

Is that a restore you did using SDR by booting up the new test server with the SDR DVD? What are the steps you took to do the restore? The test DC is in its own workgroup etc..? Do you notice anything in the event log?

Stephen Keating's picture

I manually setup a DC on the test network, along with a server to run Backup Exec on. I gave the DC the same domain name as my real network. After importing the Backup Exec files into the 12.5 version I have, I put the DC into the Directory Recovery Mode, then ran the restore of the backup to the DC. The only issue was the credentials need for the backup. Presumably with the DC in safe mode, the account I had created in Active Directory could not be found, so I use the machine Administrator and password for the credentials. After that there was no problem with the restore, only once I had rebooted, and then found all the issues after logging on.

Stephen Keating's picture

Just to make sure I understand this, I am doing the restore twice, the first time with the target computer running normally, the second time with the  target in Directory Services Mode.

Stephen Keating's picture

I have run into a problem. How do I launch the restore, when all I have is the IP address of the target? When I go in and setup Restore, it is looking for a machine on the network, i.e.: dcserver\domain.com. How do I target a machine by IP address only?

Stephen Keating's picture

More food for thought:

I added the Backup Exec Remote Agent to the target machine, and it is running, with no firewall in front of it. I used the Redirection selection of the Restore window, but each time I try to run a restore, with the correct login/password, it tells me that it cannot connect with the target, and to make sure the Remote Agent is running. I can ping the target from the media server, so I am not sure what is causing the problem. The Remote Agent I used is the Windows Remote Agent that comes with the 12.5 application.

AshutoshTamhankar's picture

 

If the system was in a specific domain or workgroup, do not join the domain or workgroup at this time.
If you are recovering a domain controller, do not perform the domain controller installation process at this time. Suggest doing a non authoritative restore. 
Stephen Keating's picture

The attached below is from my last attempt to do a restore. I solved the problem on how to restore to a machine only with an IP address, but still get the following:

 

 

Job Completion Status
Job ended: Friday, February 22, 2013 at 8:35:28 AM
Completed status: Failed
Final error: 0xe000848c - Unable to attach to a resource.  Make sure that all selected resources exist and are online, and then try again.  If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-33932

Errors
Click an error below to locate it in the job log

 

Restore- 10.10.5.200
V-79-57344-3864 - Restoring only security information is not supported for \\10.10.5.200\Shadow?Copy?Components. V-79-57344-3864 - Restoring only security information is not supported for \\10.10.5.200\System?State.

 

Stephen Keating's picture

Attached is a Word document with the log file from my last attempt to Restore.

AttachmentSize
Job Log BEX_SYMMANTEC_00022_xml.docx 13.99 KB
Stephen Keating's picture

I believe the final problem with this restore is based on which option to choose in the Restore security option in Settings > General. The three choices are:

Restore all information for files and directories

Restore only security information for files and directories

Restore aoll information except security for files and directories

 

Which of these should be chosen, the instructions are not clear.