Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

ActiveX pop up bar being blocked by Symantec Endpoint Protection

Created: 25 Sep 2009 • Updated: 21 May 2010 | 9 comments
KJK's picture
This issue has been solved. See solution.

I have installed a WCS-2040 P/T/Z Wireless IP Camera at a remote location. When I try to access the camera via the internet outside of my company network using IE, I get an ActiveX pop up bar asking if I want to install ActiveX. After clicking yes, the remote camera operates fine.

When I try to access through our company network (company network running Symantec Endpoint Protection) using IE I do not get the ActiveX pop up. The camera web page loads and looks normal except where the video image should appear there is only a small red X.

I have also noted that when I go to Mapquest using IE from our company network, the screen has many red X's on it and just does not look right.

I have tried making adjustment through IE and Symantec Endpoint Protection and am unable to to get the camera web site as well as Mapquest to view properly.

I am obviously overlooking a setting somewhere.

Does anyone have any suggestions on how to resolve this issue?

Any help would be greatly appreciated - thank you in advance! 

KJK

Comments 9 CommentsJump to latest comment

Thomas K's picture

What version of IE are you using? Are you having this issue on Vista Clients?

See steps below taken from  "How to use IP CamSecure in Vista" on page 111 of the product manual.

Step 1:
Start->Control Panel
Step 2:
Click “User Accounts”
Step 3:
Click “Turn User Account Control On or Off”
Step 4:
Disable ”Use User Account Control(UAC) to help protect your computer”, then click “OK”. Now, you
can use IP CamSecure in VISTA.

http://download.level1.com/level1/manual/IP-CamSec...

Thomas

sandeep_sali's picture

Hi,

       You mentioned that when you try to view the camera through the company network using IE I you do not get the ActiveX pop up. The camera web page loads and looks normal except where the video image should appear there is only a small red X.

Now the things to look out for are :-

  • Version of IE. Try upgrading to the latest one.
  • Try accessing the camera from an alternaate web browser.
  • Version of Symantec endpoint installed. Ideally it should be the laatest one
  • Features of endpoint installed ( AV/AS, PTP, NTP)
  • In case the machine from where you are trying to access the camera has an Server OS installed then PTP feature is not supported. If you also have NTP installed it will act as an incoming as well as outgoing firewall. This component should be thoroughly tested in a TEST environment before implementing it in a Production environment.
  • If the NTP feature is installed try uninstalling it by going to Add/remove program>>Symantec endpoint protection>>Modify and then uncheck the NTP feature.
  • Once this is done restart the machine and check the status and let us know

Thanks & Regards

Sandeep C Sali

KJK's picture

Thank you  Cycletech and sandip_sali for your responses. The software and versions I am using are :

IE Version 8
Symantec Endpoint Protection Version 11.0.4202.75
Wndows XP Professional Version 5.1

My biggest issue is I have somehow blocked the ActiveX pop up bar. I have tried to unblock the ActiveX pop up bar through IE and Symantec Endpoint Protection and am unable to to get the camera web site as well as Mapquest to view properly.

I have also tried using Mozilla but get the same results. I think the problem is a change I made in the settings in the Symantec Endpoint Protection program.

Thomas K's picture

Try adding an "Allow all" rule to the top of your firewall policy. If the camera page loads then we know the issue is with the firewall rules. You can then troubleshoot which rule is blocking your camera feed.

Thomas

SOLUTION
Jason1222's picture

If from outside of your corporate network this is working and from inside it's not, most likely the problem is not Symantec.
Have you tried logging into the machine as the local administrator (no domain) and verifying that in IE 8, it still is prompting you for the ActiveX control?

Have you looked at your GPOs in relation to ActiveX scripting??  I.E. Allow signed, prompt for unsigned or disallow unsigned, etc.

This would generally be a good place to start looking...

Just a thought.

KJK's picture
My apologies for taking so long to get back to everyone on this issue.

I want to thank Cycletech, sandip_sali, and Jason1222 for your input to resolve this issue.

Thomas (Cycletech) you hit this one right on the head “Try adding an "Allow all" rule to the top of your firewall policy. If the camera page loads then we know the issue is with the firewall rules. You can then troubleshoot which rule is blocking your camera feed”.

Again, thank you all for your help!
Peace - Out
ShadowsPapa's picture

So which rule was blocking it - or did you simply open up the firewall and leave it wide open??
The tip was for troubleshooting, not meant as the final solution - so I hope you followed up, figured out which rule it was and went from there, then remove the allow all. Otherwise, it's the same as no firewall at all........

KJK's picture

ShadowsPapa

No, did not leave it wide open. When our IT guy installed Symantec End Point Protection he either created or the rule was existing (not sure) to not allow ActiveX downloads. The gold bar would not even appear on the screen. Since the surveillance program I was running only required an ActiveX download once, he unblocked the rule and then blocked it again.

I was unaware of this but he told me that ActiveX downloads can contain potentially dangerous scripts (?). I am going to research this a little bit more only because I allow ActiveX on my home system.

Thank you for the follow-up, it is appreciated.

KJK