Video Screencast Help

Activity Monitor tweak on NBU 7.6

Created: 02 Apr 2014 • Updated: 25 Apr 2014 | 8 comments
Andrea Francesconi's picture
This issue has been solved. See solution.

Hello guys,
I recently upgraded NBU from 7.5 to 7.6.
In the past I use with success this KB note:

How to manually adjust the number of days a backup job's history remains available in the Job Activity Monitor on Windows-based Master Server
TECH24317
http://www.symantec.com/docs/TECH24317

for adjust the numbers of jobs reported into Activity Monitor.
The same settings in the new environment didn't work:
do you know how apply the correct tuning?
Thank you for any tips.
Andrea

Operating Systems:

Comments 8 CommentsJump to latest comment

Marianne's picture

NBU 7.6 Admin Guide I seems to describe more or less the same procedure in Chapter 26 under About the jobs database.

Did you restart NBU after creating the registry entry?

If entry was created correctly and you have restarted NBU, you may have found a bug.
Please log a call with Symantec Support.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Nagalla's picture

hi,

yes...

On Windows:
Use the following method to add new registry key(s) to
HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\
CurrentVersion\Config
To add the key(s) safely, run the following commands. For example:
install_path\VERITAS\NetBackup\bin\admincmd\
echo KEEP_JOBS_HOURS = 192 | nbsetconfig

Where 192 is the number of hours that unsuccessful jobs are kept in the jobs
database or Activity Monitor display.
For example, run:
echo KEEP_JOBS_SUCCESSFUL_HOURS = 192 | nbsetconfig
Where 192 is the number of hours that successful jobs are kept in the jobs
database or Activity Monitor display.

 

see page number 1030 in Netbackup 7.6 admin guide 1 for more details.

SOLUTION
Andrea Francesconi's picture

Thanks for all your tips.
Honestly I don't remember if we restarted NBU services after the upgrade: I restarted services right now.
Registry keys still configured as well after upgrade.

SymTerry's picture

When looking at HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\CurrentVersion\Config, I would like to know what values you have for KEEP_JOBS_SUCCESSFUL_HOURS and KEEP_JOBS_HOURS? Do you even have those keys?

Try running the nbsetconfig commands again and see if those keys are changed. 

I looked and don't see any current bug mentions for this, but did see engineering working to integrate this process into the GUI in a future version of NetBackup. That will be a nice add. 

Andrea Francesconi's picture

NBU services were restarted but the issue persist.
Registry keys are configured, take a look:

20140404_003.png

When I run nbgetconfig I can see reg keys configured:

20140404_004.png

If don't understand if I need to remove these keys from regedit then add them again by netsetconfig utility indecision

Marianne's picture

Try to change the value with netsetconfig and see if the registry entry gets updated.

Please log a call with Support if this is not working for you.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Dyneshia's picture

When you restarted services ( which is needed when you update KEEP_JOBS_SUCCESSFUL_HOURS) did you run a bpps and confrim everythign is stopped before starting back services ? 

Andrea Francesconi's picture

Hello guys,
I tried Nagalla's tip:
I specified a different value for both values (from 720 to 721) and seems working.
I'll update you next week about results.