Video Screencast Help

AD Import not working

Created: 25 Feb 2013 • Updated: 25 Feb 2013 | 2 comments
This issue has been solved. See solution.

I just noticed that our AD import for computers isn't working at all - only about 50 computers out of 800 or so have imported, despite a manual run showing as completed successfully. I checked the logs and the general results are:

- Found and processed 66 OU's OK (and they exist)

- Found and processed 879 computer resources - says 100% complete but they don't exist.

Immediately afterwards, there is an error like this:

EventRouter could not deliver the following file..

ServerBusyException: Queue was full

Everything else seems to be working OK. Could the error be related?

Comments 2 CommentsJump to latest comment

andykn101's picture

Yes. AD Import works by treating the AD information the same way as inventory, it put the information into NSE files and puts them into the Event Queue. If your Event Queue is full it can't, I'm not sure what it does in that case, clients just queue Inventory data on the client and post it later when the queue isn't full.

Find out why your queues are full, is the NS processing any events, has a service stalled?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

SOLUTION
ukDavidC's picture

Thanks, I had a look at the queues and there were ~3000 items stuck there. I restarted the server and over a few hours it processed and now is at zero. Running the AD import then worked.

Thanks for your prompt help.

Please don't forget to mark your thread solved with whatever answer helped you : )