Video Screencast Help

Adding files to Ghost WinPE Boot Packages

Created: 01 Aug 2013 | 1 comment
Steven Moran's picture

I am attempting to add the DeployCenter executables to a Ghost WinPE boot package.  Yes, I know that they are 16-bit and running those in WinPE might not work at all, but I have a different issue to resolve first.  I am testing my work in VMWare Workstation, for both Ghost Server and Client.

There is a step in the Ghost Boot Wizard where one can add files to the boot package and choose/create a directory to contain them.

My first attempt was creating an ISO.  After some trial, error, and poking, I discovered that the files do not appear to be in the WinPE PreOS that the client boots to, but are visible at the root of the ISO itself.  This appears to be the case with a USB drive as well.

In another attempt, I created a One-Click Virtual Partition.  The files were visible in the PreOS, but when attempting to run the executables, I was told that they could not be found.  They were also visible in the vpartition.zip file

How can files be consitently placed on, and accessed from, the PreOS when added via the Ghost Boot Wizard?

Operating Systems:

Comments 1 CommentJump to latest comment

EdT's picture

Probably the simplest way is to mount the boot.wim file from your WinPE boot image and then you can edit the actual Pre-OS to your heart's content.  Of course, it would also be trivial to add a batch script that can find your boot CD and run any content on the root of the source ISO.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.