Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Adding Intel Chipset and AMT Driver to Driver Database

Created: 28 Aug 2014 | 13 comments

I am using Altiris Deployment Solution to create a hardware independant image.  After deploying the image, I have 2 devices that have "Missing non critical drivers"

The devices in question are "PCI Serial Port" which is related to the Intel AMT chipset and "SM Bus Controller" which is part of the Intel on-board chipset.

I found the drivers for these from the manufacturer website, but Driver Database Management will not let me upload them to the DriverDB.

The message I get is "1 Driver(s) were attempted for import, 0 driver(s) were successfully imported.".

The only reason I can think of this happening is because the drivers in question only have a .INF and .CAT file.  I noticed other drivers that have successully uploaded have a .SYS file as well.

Does anyone know a way to get these chipset drivers added to the DriverDB?

Thanks for your assistance.

Operating Systems:

Comments 13 CommentsJump to latest comment

Thomas Baird's picture

You'll want to call that one in.  You're in DS 7.5, right?  SP1 or later?  If not, update your DA and/or test this in a lab.  Getting older versions of DA fixed are like pulling teeth.

IF you can't get them in, you could either script them in, or use a post imaging installation "job"  We had to do that with some video drivers a couple of times...

Thomas Baird
Enthusiast for making things better!

 

Bowerst2's picture

Thanks for response Thomas.  We are at DS 7.5 SP1.

Some clarification:

This is the driver package in question:

http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=T7WCW&fileId=3098294068&osCode=W764&productCode=optiplex-790&languageCode=EN&categoryId=CS

It is basically a standard .INF update package that allows windows to correctly identify Intel chipset components.  Intel offers a similar package which I have also had the same results with.

https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=20775&lang=eng&ProdId=816

I would like to avoid scripting if possible and I was hoping that DS would be able to handle something that seems very simple.

 

 

 

Bowerst2's picture

Thanks for the response.

Yes we are running DS 7.5 SP1.

Was hoping to avoid scripting or post install jobs if possible, but we may have to do it if there is no solution.

 Has anyone else had issues with the standard Intel Chipset Identification drivers?

 

 

Thomas Baird's picture

It should, and if it is not, again, it needs to be called in so they can fix it.  I would "guess" the problem is that this driver is an expansion of another driver.  Sometimes, drivers are "released" that actually just point to another driver and say "Oh, by the way, that driver will work for these devices too - even though you didn't know that" and don't themselves carry any real information - just pointers.  Those kinds of drivers tend to fail, or they used to.

 

Call it in and see.

Thomas Baird
Enthusiast for making things better!

 

Lark's picture

I've seen the same problem with DeployAnywhere in 6.9 SP6.  I've even tried a little transplanting with the most up to date version I can find as both versions now seem to share the same files and DS 7.5 has newer versions.  It works fine but didn't improve the situation.

About the only driver I can rely on it for is NIC drivers.

 

Lark's picture

Just to add a little more to this thread I checked 7.5 SP1 HF2 and it has a newer version of DeployAnywhere.  That might be worth trying.

Phil_W's picture

I tried uploading this driver with 7.5 SP1 HF2, same result.

I wonder if it is because, for each of the device ID contained within the inf files they all state no driver required i.e.

%IntelDeviceDesc%=Needs_NO_DRV, , PCI\VEN_8086&DEV_0E1E

Therefore the driver manager cannot find anything to actually upload.

Phil

Bowerst2's picture

Thanks for checking that Phil.  I would hope at least that Deployment Manager would be able to store the INF file and install it even without the driver.  But maybe it isn't designed to do that?  

 

I am going to open a ticket and see what Symantec says.

Matthew Koeman's picture

Hi, did you resolved this? i have the same INF driver that i want to add to the driver DB,

if not i will open a case @ symantec Support 

Bowerst's picture

I escalated it to Symantec Support.  They were not able to get the chipset INF files to upload to the driver DB either.  They escalated it to their programmers to look at.  The support technician mentioned that someone else had already opened a case and the programmers are aware.  

It looks like this is a feature that will need to be added before this works...

May help speed things along if you open a case too.  Not sure.

Thomas Baird's picture

THIS is the reason many of us use custom scripts and DISM to inject drivers.  I've NEVER had DISM fail on a driver.  Granted, it's a bit more work to do it yourself, but it's clean, and it's fast.  The only down-side compared to DS 7.5 is that is requires a drive mapping.  :(  huh... UNLESS you used a copy file task maybe...  heh.  THAT'd be cool.  A copy file task to pull the files down locally via HTTP, then run DISM locally?  huh.  I'll have to ponder on that.  Anyway, the script we use does us a drive mapping, but fast, and effective.

Sadly, I really wish I could say DA is the end-all be-all.  I really do.  I like, fundamentally, what it does.  What I don't like is how often I see "this" kind of issue, and suddenly a customer is just - DOA - waiting for Dev (who is like always busy) to find an answer before they can move forward.  It's not like imaging can be just put on hold for weeks!  Yaknow?  That's why even when I worked there I acknowledged that scripting DISM is a good idea as a work-around.  It was sorta fun to put that into practice!  :D

Thomas Baird
Enthusiast for making things better!

 

hmh_it's picture

Did you ever get a script going, i need to get those drivers added as well.

Bowerst's picture

Unfortunately, we had a reduction in force at my company and I was assigned to another team.  I am no longer working on this issue.