Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Adding third node to VCS Cluster - (Solaris 10, NBU 6.5.5)

Created: 23 Aug 2010 • Updated: 28 Jan 2013 | 3 comments
This issue has been solved. See solution.

Hi,

I'm currently running a Master Server which is a VCS Cluster with two nodes. I need to add a third node to the cluster and am struggling to find any doco on it (apart from the high availability guide which explains configuring from scratch).

Does anybody happen to have any doco on this or is able to point me in the right direction? Apart from the VCS side, I'm assuming that I'll probably need to run cluster_update and configure from there, along with adding the extra node via nbemmcmd, etc. Thanks.

Dublin

Comments 3 CommentsJump to latest comment

Marianne's picture

There is no documentation... I had to add a second node to a one-node cluster recently. I had to apply every bit of SF/HA as well as NBU knowledge to work out a procedure.
I tested it in our lab, documented the procedure and then proceeded with the change at the customer's site. Needless to say that there were so many differences at the client's site that I ran into reveral problems. We eventually got it right, but because of individual differences, it's difficult to publish a 'how to' document.

Under no circumstances can cluster_config be run in an existing environment - it simply discards (NOT copy) all existing databases (EMM, Images, policies, etc) and create them as new on the shared disk.

The easiest will be to upgrade first to NBU 7 - adding nodes is made REAL easy. If the new node is already in the cluster, if will prompt if you want to join the existing cluster and then proceed to add config the new node.

Unfortunately there is STILL a need to have rsh enabled for this process...

You need to follow VCS documentation to install SF/HA and join the existing cluster (In VCS Install Guide under 'Adding and removing nodes' - manuals: https://vos.symantec.com/documents). 

This new behaviour is described as follows in the NBU HA Guide:
4 When NetBackup is installed on the clustered setup a confirmation prompt is displayed.
■ When installing NetBackup on the first node, you are prompted to confirm creation of a NetBackup cluster. Type Yes to set up NetBackup in HA mode.
■ When installing NetBackup on the subsequent nodes, information of already created NetBackup cluster group is displayed. You are prompted to join the group.
5 When you are prompted for cluster specific configuration details, refer to the checklist and provide details  accordingly.
6 Allow NetBackup to be installed in a cluster. When a NetBackup failover server is installed:
■ On the first node, a single node cluster resource group for NetBackup is created and brought online.
■ On the other nodes, the installed node is added to the cluster resource group.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

dublin101's picture

Thanks..yeah cluster_config is one I would definitely not run.

Unfortunately I cannot upgrade to 7, I am forced to stick with 6.5.5. 

The VCS part will be taken care of by a VCS Specialist from Symantec - so I have that part covered. Its just the NBU part I'm at now where I'll need to put a plan together. Unfortunately there isn't much doco out there, not even simple doco which states the main steps of adding a new node. That said, I'll have to dig deep and allocate more time to testing.

Thanks.

Marianne's picture

So - I was wrong about no documentation - please see this TN:

http://www.symantec.com/docs/TECH62860

The cluster_add_node script is available from NetBackup 6.5.2 Release Update....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION