Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Adobe Reader not working with my language

Created: 19 Feb 2013 • Updated: 12 Mar 2013 | 11 comments
This issue has been solved. See solution.

Whenever I try to virtualize Adobe Reader it always defaults to English language. I've tried forcing it through registry and MSI properties but nothing works.
If I install the software without the capturing agent running it works as expected with other languages. Anyone else having issues with this?

Version tested: 10.1, 11.0 and 11.0.1
OS: XP and W7 (clean installs with updates)
Virtual Composer: 6.1 SP8 (6.4.0.591_35765)

 


 

The registry looks like this

 

[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Language]
"UI"="NOR"
 
[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Language\current]
"@"="Locale\nb_NO\RdLang32.NOR"
 
[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Language\next]
"@"="Locale\nb_NO\RdLang32.NOR"
 
[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Language\UseMUI]
"UseMUI"=dword:00000000

 

The customization wizard doesn't have any language option except for the possibility to edit the MSI property "LANG_LIST" removed any other language but the one you want. But really that doesn't help since english can't be removed and is being set as default anyways.

For what it matters I started with the enterprise installer of Adobe Reader 11.0 MUI + patch to 11.0.1 - but really that doesn't matter because the normal installers act the same way.

Comments 11 CommentsJump to latest comment

EdT's picture

Have you created the package using Adobe's Enterprise configuration tool?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Anders Haga's picture

No I hadn't,but I tried and I'm getting an error stating "Run-time error '13': Type mismatch".

EdT's picture

That error looks like some sort of scripting error - I've seen these errors in Excel macros. Can you confirm that you are testing the Adobe application on a clean build, to make sure there are no conflicting errors arising from other apps?

Looking back at your original posting, I note you had problems with a capture of the Adobe Reader app. As you are capturing an MSI, are you ensuring that there is a copy of the MSI file cached in C:\Windows\Installer (normally a system folder).

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Anders Haga's picture

I'm capturing on a clean Windows XP machine (VMware workstation) with windows updates and runtimes (.NET, VC++, MSXML). I do rollbacks before each application capture.

A local cache of the installer is present in c:\windows\installer.

EdT's picture

Since the Adobe installer is an MSI, I would recommend capturing the install with verbose logging enabled so that you can check your log to see whether the appropriate language settings have been applied.

Incidentally, does the same process work correctly if you install to the base rather than into a layer?

Are you capturing on an English operating system or an operating system for the target language you are packaging?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Anders Haga's picture

I'll do a capture with logging and answer back when I've gone through it.

Regarding the base layer, yes, it works when installing without capturing. Target system and workstation language is Norwegian.

EdT's picture

Something you may want to check - not sure if Adobe still do things this way, but certainly in the past, the registry area under HKLM/Software/Microsoft/Windows/CurrentVersion/Uninstall/<adobe product code> tends to be excluded in capture engines, yet is used to store some configuration information. There may also be stuff stored in <user profile>\application data\adobe and again there are various excludes on capture that may be affecting you. You may want to install to the base on one machine, and compare these various areas with a capture into a layer.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

michael cole's picture

Related issues for comparison, though the key difference here is that you get it to work via normal means

http://www.itninja.com/question/adobe-acrobat-8-standard-languages

 http://appsensebigot.blogspot.ie/2012/04/non-english-adobe-reader-x-reverts-to.html

Second link is interesting, can it be possible the attempt of executing temporary files int he profile in a non writeable layer could cause that?

Woudl making a global exclude on some areas narrow down exactly what's happening?

Michael Cole

Principal Business Critical Engineer

Business Critical Services

ksreek's picture

I just experiened the same problem while packaging internally and found that "Enable Protected Mode at startup" flag during capture seem to have created this problem.

Can you try capturing using a command prompt and initiate the Adobe Reader installation ? Once installation is complete without closing the command prompt can you try the following ?

 

P.S : Please note that your capture continues until the command prompt is closed.

  1. Launch Adobe Reader XI. (From Command Prompt)
  2. Go to Edit > Preferences > Security (Enhanced).
  3. Uncheck Enable Protected Mode at startup.
  4. Restart Adobe Reader.
  5. Go to Edit > Preferences > Language.
  6. In the Application Language dropdown, choose Choose at application launch.
  7. Restart Adobe Reader.
  8. A dropdown will appear asking for the application language. Select the desired language and choose OK.
  9. Adobe Reader will be launched in the selected language

Thanks

 

SOLUTION
AngelD's picture

If I recall that issue was resolved in earlier version (than latest of today).

Could it be that the problem has sneeked in again?