Video Screencast Help

Advanced formatting of a grid view

Created: 25 Jun 2012 • Updated: 17 Sep 2012 | 3 comments
This issue has been solved. See solution.

We are using Symantec Management Platform 7.1. I access the console from Windows 7 Enterprise 64-bit, with IE9.

 

I have been trying to do some formatting of a report, to make some of the information stand out.

I looked in the user guide for the platform, and found out how to do the formatting on page 570-571, but I have a problem.

I follow the steps in the guide:

  1. Click Add under Template Field
  2. Specify the settings that I want to use
  3. It says to click "Insert", but I have no button or anything that says "Insert"

Can anyone tell me how to get the "Insert" button or link ???

What do I need to repair to get the button to show up ???

 

I have attached a screenshot of what I have available to me. No "Insert" button anywhere.

Comments 3 CommentsJump to latest comment

LCode's picture

I am currently facing the same problem. No Insert button is visible in 7.1 SP2
Conditions and template fields are also not saved when I click on Apply or Save Changes.
They just disappear.

IT Consultant - IT LifeCycle Management/Symantec Endpoint Management @Xylos

LCode's picture

After some testing and analyzing existing reports I have found a manual solution.

  1. Create a formatting rule in your report and save it.
  2. Export the report
  3. Edit the XML and modify the formattingElements-section
  4. Import the modified XML

Sample of formattingElements-section

<formattingRules formatAllLevels="True" levelFormatting="10" applyFormatting="True">
<formattingElements>
<formattingScript><![CDATA[]]></formattingScript>
<formattingStyle><![CDATA[]]></formattingStyle>
</formattingElements>
<formattingRule name="NegativeDelta" format="html" column="Delta" conditional="True" priority="1">
<conditions><condition conditionValueExtra="" conditionValue="0" comparator="<" columnValue="Delta"/></conditions>
<fragment>
<fragmentData><![CDATA[<span style='font-weight:bold; color:red;'>{0}</span>]]></fragmentData>
<fragmentFields>
<fragmentField>
<mapping>0</mapping>
<value><![CDATA[Delta]]></value>
<source>DataSource</source></fragmentField></fragmentFields></fragment>
</formattingRule></formattingRules>

formattingRules

  • formatAllLevels: set this to true
  • levelFormatting: set this to 10
  • applyFormatting: set this to true

conditions

  • You can define this elements via the console. Press enter after define settings for new condition to save it. And save report

fragmentData

  • Contains the HTML-code to display the item. It points to a numbered item. Number of item is defined in mapping.

fragmentField

  • mapping = unique field ID (integer)
  • value = name of source field
  • source = datasource. Default datasource is DataSource

After inserting this piece of formatting you can edit it via the console.

IT Consultant - IT LifeCycle Management/Symantec Endpoint Management @Xylos

SOLUTION
CBaelum's picture

Not the easiest way to get this working, but still better than not being able to do this.

Hope a proper fix will be made some day.