Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Advice Needed for upgrading to BExec 2010 R3

Created: 17 Sep 2013 | 6 comments

Hopefully someone can answer this for me.

We have a Windows 2008 SBS Server running BExec 2010 R2. There is now a constant issue where the backup fails when it gets to the Exchange side of the backup with the following message :

Backup- \\xxxx\Microsoft Information Store\First Storage GroupV-79-57344-759 - Unable to complete the operation for the selected resource using the specified options.  The following error was returned when opening the Exchange Database file:  '
n/a
'
We are using GRT in order to backup individual mailboxes onto a NAS Box.
 
Would moving to R3 resolve this issue or is there an alternative solution. Running a live update does not give me R3 as an optional upgrade. Would I need to buy additional Symantec maintainence in order to be able to upgrade?
 
Any help would be much appreciated.
 
Thanks,
 
Simon

 

Operating Systems:

Comments 6 CommentsJump to latest comment

lmosla's picture

Hello Simon,

The upgrade from R2 to R3 is not available from Live update see here for the download: http://www.symantec.com/docs/TECH159346

I strongly recommended to upgrade to R3 as it has fixed most of the known issues of R1 and R2. 

Your current license is enough
 
the upgrade is pretty straightforward 
for best practices please make sure all of the live updates are installed and pushed out to your remote servers
and for extra security it is reccomended to stop all the BE services, including the Backup Exec DB instance, then make a copy of the Data and Catalog directories under the Backup Exec installation directory. 
 
VJware's picture

The error is pretty generic and would recommend to confirm few things..

1) Is the Agent for MS Exchange license installed on the Backup Exec server ?

2) Does a non-GRT backup complete successfully ?

3) Does a GRT backup to a local disk or tape complete successfully ?

4) Split off the Exchange resource from the SBS backup job and back it up using another job. Ensure Advanced Open File Option (AOFO) is disabled.

5) Lastly, run vssadmin list writers using cmd on the server. Verify if the exchange writer is listed or not. If it's not listed, enable the writer using this KB - http://www.symantec.com/business/support/index?pag...

 

simonpieman's picture

Thanks to you both for your respective replies.

I think moving to R3 may solve the issue as I have another client running it with a similar configuration and has none of the issues mentioned.

As regard VJware's observations, I will answewr them in order :

1. The agent for Exchange is installed.

2.NON GRT Backup is not a solution. I cannot go through a restore of 34+ GB to restore an email. It is not managable, nor proportional. I would like to add, that the backup used to work fine. After about a year, it would start to come up with the error. A reboot of the server would normally cure it. 

3. Occasionally, the GRT backup does succeed.

4.I did as you suggested the other day to try and isolate the issue. The backup worked and I then turned on AOFO and it stopped working. Last night after it failed, I ran the job again manually and it worked. So it is completely sporadic.

5. I don't think this applies as the backup does complete sometimes. I think it is more of a version issue.

 

One final thought... I obviously have my licence key information for the server. However, I am currently without my Serial No. Therefore, I cannot download R3 at present. Would Symantec have any suggestions how I can re-obtain my Serial Number ?

 

Many thanks.

 

VJware's picture

Serial number can be obtained from customer care. Their contact info can be found at - http://www.symantec.com/support/assistance_care.jsp

Else, you can download from this direct link - http://trialware.norton.com/files/fc/Backup_Exec_2...

Non-GRT is not a solution, rather an isolation if the issue lies with GRT processing or not.

The backup worked and I then turned on AOFO and it stopped working. Last night after it failed, I ran the job again manually and it worked.

AOFO is not meant to be turned ON for database backups such as exchange backups & hence the suggestion for splitting off the backups. When backup fails, are the exchange vss writers in a failed state ?

Colin Weaver's picture

As you have a working, licensed 2010 installation, the besernum.xml will contain your license details and can be used with the import button in 2010 R3 is anything happens during the upgrade - it will just use the installed licenses if you inplace upgrade

simonpieman's picture

I am downloading the R3 software from the direct link you provided. 

I have turned off the AOFO on the email backup to see if it resolves the issue. 

I appreciate your comments about Non GRT backups. However, why would it backup some of the time using GRT ? Added to which this has only started happening over time. Nothing on Backup Exec has changed apart from installing patches to try and resolve the issue.

I did check the VSS writers and Exchange is listed as being in a stable state.

I will try installing the R3 software in a couple of days when I am in the office and then report back as to whether the issue is resolved.

Thanks for your input.