Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

aex-agent-install-config.xml and Mac Altiris agent installs

Created: 07 May 2013 | 7 comments

I am trying to make the altiris agent install on a mac more "friendly".  I don't want my techs having to drop to terminal window tying in commands when they know very little about Macs to begin with. 

I tried using the aex-bootstrap install from the website and tryign to make it into an app that had out NS server name in it.  Has no success but might not have been doing it corrrectly. 

Then I read about installing the base agent as a .pkg and using a file called aex-agent-install-config.xml.  What I was hoping to do is make the xml file and put it somewhere in the AltirisAgent.pkg so that it would install and use the xml file.

This is also not working.  I was wondering if anyone could tell me what to do or know an easy way to make aa simple app to install the Mac Altiris agent.

Operating Systems:

Comments 7 CommentsJump to latest comment

JAunmc's picture

Update:  I have had some success and a problem.  First I used 3 files; the AltirisAgent.pkg, .aex-agent-install-config.xml, and a config.command file I created.

I zipped the 3 files into a single file.  So now you can download the .zip file to your Mac desktop, run the AltirisAgent.pkg install first, then run the config.command file.  The config.command file copies the xml file into the /tmp folder then executes the aex-configure -configure command.

Configure.command:

#!/bin/bash
cp ~/desktop/install/aex-agent-install-config.xml /tmp/
mv /tmp/aex-agent-install-config.xml /tmp/.aex-agent-install-config.xml
cd /opt/altiris/notification/nsagent/bin
sudo ./aex-configure -configure
killall terminal
 

Seemed simple enough and seemed to be working but on my test Mac the Inventory agent will not install. I see it under software delivery but if I look at the run history ir says "Operation not permitted"

Can anyone help me?

JAunmc's picture

Update2: I ran the Incentory agent installer from a command line window and got this error message:

 

Installer: Error - Altiris Inventory Solution for UNIX, Linux and Mac cannot be installed on this computer, because it requires Altiris Client Task Agent for Unix, Linux and Mac Version 7.1.6900 or higher.

 

I checked and I do not have the task agent installed.  How do I get that installed???

JAunmc's picture

Update: Success!

So I finally got something to work that I can live with.  I downloaded the aex-bootstrap-macosx file and created a .command script to kick off the commands and the install.  zipped them into a folder and that was it.  The zip file has to be downloaded to the desktop and opened.  Then just click on the command and it installs great.  Once it is installed trash the zip and the folder from the desktop and you are done.

Configure.command:

#!/bin/bash

sudo chmod u+x ~/desktop/install/aex-bootstrap-macosx
cd ~/desktop/install
sudo ./aex-bootstrap-macosx http://ns.server.name

killall terminal

Andrei Fedulin's picture

Hi JAunmc,

You have installed only agent core, but it is not enough. You should install all plugins (Client Task agent, BaseTaskHandlers, Inventory Agent Framework, SMF Framework etc.). All these packages are  available in NSCap/bin/UNIX/Agent/ on NS - I guess from folder you got core agent package.There is also agent-upgrade(and some plugin rollout scripts) script that can help you correctly install all these packages.

All these packages are downloaded automatically by aex-bootstrap if you do pull install. But during "native" package installation" you should insstall all these packages manually. 

If you have Mac OSX Package Manager, I believe you can compose one package from all agent plugins and install it in friendly manner. The only problem I see is agent configuration...I will look at this and will post you results.. 

Thanks,

Andrei

Darkthorn1's picture

I would be interested in this OSX Package Manager as well once you have it figured out.

Regards, Debbie

Debbie Thornley

Altiris Adminsitrator/State of Nevada

JAunmc's picture

Everything already works fine.  All my agents get installed correctly.  Try it for yourself.

 

I am using the same bootstrap installer that you would use from the server.  Policies bring the rest of the agents down like they normally do.

Darkthorn1's picture

Did you have to configure the MACs to be able to accept the clients? We had to touch each PC in the beginning to create a standard before we could get teh clients to install and wondering if we are going to have to do the same for the MACs. We received a few iMACs as part of a grant so we wont have many and I dont want to spend a lot of time or trouble trying to get the agents installed and configured.

Thanks for any insight,

Debbie

Debbie Thornley

Altiris Adminsitrator/State of Nevada