Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

AexNSAgent.exe high CPU usage

Created: 25 Feb 2013 | 4 comments

Hi we are experiencing high CPU usage by the altiris agent, this causes the agent to either freeze or very slow to download packages.

Server:

Windows server 2008 R2, NS Version 7.1.8400, 8000 clients

Clients Windows 7, Symantec Management agent 7.1.15400.8400

Fixes tried so far

Set the server for the altiris agent to the following using the following script.

 Option Explicit
Dim objShell
Set objShell = CreateObject("WScript.Shell")
' Run SC.EXE to set recovery options to 'Restart the Service'
objShell.Run "cmd /c sc failure AeXNSClient reset= 86400 actions= restart/5000/", 1, True
' Delete object
Set objShell = Nothing
WScript.Quit(Err.Number)

Checked there are no files 0 lenght in the program files\altris agent\queue or tasks folder.

Any further idea?

Catherine

Operating Systems:

Comments 4 CommentsJump to latest comment

andykn101's picture

Is it this:

"AeXNSAgentHostSurrogate32.exe uses a lot of memory on Windows 2008 R2 Servers"

  Problem

Windows 2008 R2 servers increases the memory used during inventory scans. The memory is never released. If you frequestly restart these servers then the issue with not be as apparent.

Environment

ITMS 7.1 SP2

Cause

The problem appears every time an inventory scan runs.

Solution

The fix for this issue will be in the next release.

http://www.symantec.com/docs/TECH192853

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

cathossie's picture

Sorry I didn't mean the issue was with the server itself although this could explain the slow issues on the server itself

Issue is the agent on the client machines that is constantly using around 50% CPU usage, I have checked the clients and they are not running inventories whilst this is happening. Some clients have the aexnsagent process using 50% cpu usage even when nothing appears to be happening on the agent.

I have seen that there are xml files are being constantly written in the C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\data - I'm not sure what these files are but on some machines I have noted 49 new files within 1 minute and I'm wondering if this may have something to do with cpu usage the agent also locks up and takes time to respond.

andykn101's picture

Look in the Altiris log on a client PC using the Remote Altiris Agent Diagnostics (RAAD) tool and see if there are lots of things running that shouldn't be or lots of errors. Check the task history too.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Sachin Sawant's picture

Kindly check Windows System Assessment Scan police running on this time.