Video Screencast Help

After moving BEDB to new server(SQL server) the Backup Exec Device & Media Service do not start

Created: 17 Jun 2013 • Updated: 17 Jun 2013 | 4 comments
This issue has been solved. See solution.

After moving BEDB to new server(SQL server) with BEUTIL, the BE services will not start 

The BEUTIL move went without any problems, BE 2012 is running on server1 (2008 R2) and the SQL server is running on server2 (2008R2) 

I get event ID 7003, The Backup Exec Device & Media Service service depends the following service: MSSQL$instance. This service might not be installed.

This is correct that the MSSQL$instance instance do not exist on server1, because it is moved to server2. How can I change the BE config so the BE services do not depend on the SQL on server1 but on server2

 

Operating Systems:

Comments 4 CommentsJump to latest comment

Colin Weaver's picture

You will probably need to get some registry adjustments made - I would siuggest you log a formal support case.

 

Also I hope you did not move the BEDB to a SQL instance that is shared with any production applications as this is not a recommended configuration. The BEDB should really have it's own SQL instance.

VJware's picture

I have pinged you for some info. Would you pls confirm so.

EDIT* (For the benefit of others)

Device & Media service had an incorrect dependency. We corrected by editing the key "DependOnService" from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BackupExecDeviceMediaService

ZeRoC00L's picture

I think you have to modify the registry so that the BE services do not depend on a (non existing) SQL service.

If this response answers your concern, please mark it as a "solution"

SOLUTION
CS_Symantec's picture

Removing  MSSQL$BKUPEXEC from Backup Exec Device & Media Service service dependensies solved the problem