Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

After restoring Image, pc keeps on restarting

Created: 24 Aug 2009 • Updated: 21 May 2010 | 11 comments

Hi,

At our company, we took an image of a pc (Dell).
When I try to restore it to a lenovo (right from the box, isn't used before) my image restore but when the pc restarts it's getting to the screen of Startup in safe mode.

I tried al the startup modes and they don't work. The pc keeps restarting.

Can someone help me please?

Thnx!

Discussion Filed Under:

Comments 11 CommentsJump to latest comment

G-3Manticore's picture

Hello

Did you use sysprep before, to load the important storage driver into the image?
Is the lenovo-storage configuration at native-ide set in bios, and are the chipsets the same? If not,  that's the reason for the startup-screen. Can you enable the blue-screen of death, instead of automatic restart option, only to see, where the prob is.

greetings

alexander emmer

Wizgirl's picture

Didn't use sysprep before. I will search for information.

I will look for the chipset types and the Bios setting.

The weird thing is that some of the pc's do work and some not.

I had a blue screen when i used the windows xp cd to restore the system.

Sorry for the noobie question but how can i enable the bluescreen?

Thnx

G-3Manticore's picture

After post screen, press F8 to access the advanced boot options, where you can select "start in safe mode" etc. There must be a point where you can disable the automatic restart when an error occurs.

The blue screen show-up with the xp-cd leads to the point, that you have ahci enabled, or the storage /chipset could not be loaded during startup. Set the setting to Native-IDE in Bios, and you should access the repair console in windows. There you could load the chipset driver through floppy into your data system.

Greetings

alexander emmer

EdT's picture

You definitely need to use Sysprep before deploying any image to more than one machine, otherwise all the internal security settings are duplicated, and you cannot have this in an enterprise environment as each machine MUST have unique internal security settings.

Secondly, with the huge number of different models that Lenovo manufacture, you are just as likely to experience problems imaging one model and restoring that image to a different model. Some Lenovo machines don't even use the same HAL.

It's a lot like trying to take a truck tyre and expecting it to fit on your car, or your bicycle.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Wizgirl's picture

We don't deploy 1 image to more then one machine.
We take an image from the old pc, deploy it to a new pc and remove the old pc.
We do this for every pc, never deploy an image to more than one machine.

I'm still looking to disable the automatic restart when an error occurs. When I'm in the screen of safe modus, i can choose between different startup modus but i can't see where i can disable the option.

I changed my lenovo-storage configuration to native-ide set in bios and now i'm looking how to work with sysprep :-)

I'm here temporary and normally i only install sql server but this is the first time that i'm working on a helpdesk.

Thanks for the information, i'll keep you posted

Wizgirl's picture

Last question

Can it be that the problem occurs because i'm using the gui ghost instead of command prompt?
I have read about parameters but i'm not sure which one to use.

G-3Manticore's picture

There should be no problem at all, using GUI Ghost instead of command-line based ghost. It's like EdT already said. The old-configuration seems to be different, so you have to bind the new storage and chipset driver into the image at least. then you need to sysprep or ghostwalk in order to change the SID.

Wizgirl's picture

Ok,

My day is over but tomorow i will dig into sysprep.

Thanks for everything!

Wizgirl's picture

Hi,

I've read about sysprep and followed an example.
I downloaded all the drivers for the new pc, extracted them, changed the sysprep.inf file, made an image and restored it. No success.
Maybe I did something wrong.
Before I took the image, I changed the driver for the APCI to "Advanced Configuration and Power Interface (APCI) PC. Before it was Standard Pc

There is something I discovered.
We installed a few lenovo pc's with the model number 6078-A66 and when I restore the dell image to that model it works!
When I deploy the dell image on a Lenovo 7630-AJ9 model it doesn't work.

The problem is that we installed the first models and we don't have spare ones. They all got an owner now.

Maybe we have to change the "old" lenovo's with the new ones and reinstall all the pc's....

This is my sysprep.inf file:
 

[Unattended]
    OemPnPDriversPath = "Drivers\1\1;Drivers\2\1;Drivers\3\1;Drivers\4\1;Drivers\4\2;Drivers\4\3;Drivers\4\4;Drivers\4\5;Drivers\4\6;Drivers\4\7;Drivers\4\8;Drivers\5\1;Drivers\6\1;Drivers\7\1;Drivers\7\2;Drivers\7\3;Drivers\7\4"
    DriverSigningPolicy=Ignore
    InstallFilesPath=C:\sysprep\i386
    TargetPath=\WINDOWS
    KeepPageFile=0
    OemSkipEULA=Yes
    UpdateInstalledDrivers=Yes
    NonDriverSigningPolicy=Ignore
    UpdateServerProfileDirectory=1
[Sysprep]
    BuildMassStorageSection=Yes[GuiUnattended]
    EncryptedAdminPassword=NO
    OEMSkipRegional=1
    OEMDuplicatorstring="Demo Clone"
    TimeZone=105
OemSkipWelcome=1
    AutoLogon=Yes
    AutoLogonCount=3[UserData]
    FullName="Our Company Name"
    OrgName="Our Company Name"
    ComputerName=*[Display]
    BitsPerPel=32
    Xresolution=1024
    YResolution=768
    Vrefresh=72
    AutoConfirm=1[TapiLocation]
    CountryCode=1
    Dialing=Tone
    AreaCode=719
    LongDistanceAccess="9"[RegionalSettings]
    LanguageGroup=13,17,3,2,5,16,4,12,15,7,8,11,9,6,10,14,1
    Language=00000813[Networking]
    InstallDefaultComponents=Yes[Identification]
    JoinWorkgroup=Workgroup[GuiRunOnce]
    Command0=c:\drivers\scripts\cleanup.bat[SysprepMassStorage]
    *pnp0a00=c:\windows\inf\machine.inf
    *pnp0a01=c:\windows\inf\machine.inf
    *pnp0a04=c:\windows\inf\machine.inf
    *pnp0a03=c:\windows\inf\machine.inf
    pci\cc_0604=c:\windows\inf\machine.inf
    pci\cc_0601=c:\windows\inf\machine.inf
    pci\ven_1055&dev_9130=c:\windows\inf\mshdc.inf
    pcmcia\micron-mtcf____-392d=c:\windows\inf\mshdc.inf
    pci\ven_1179&dev_0105=c:\windows\inf\mshdc.inf[Branding]
    BrandIEUsingUnattended=Yes[Proxy]
    Proxy_Enable=0
    Use_Same_Proxy=0
EdT's picture

A build with a non-ACPI HAL cannot be used on a machine with an ACPI HAL (Hardware Abstraction Layer)

On the working machine, check the properties of the file HAL.DLL - especially the original filename. HAL.DLL is always a copy of one of the many HAL files that windows installation disks carry.

On the failing machine, perform a clean installation of your operating system using the CD media. Just the most basic install that will boot up OK. Then look at the HAL.DLL on this machine and check the original filename of this file.

If the two files are the same, then this is NOT the issue with your build. However, if they are different, then you will need to create a separate image for your Lenovo machine.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Wizgirl's picture

Hi,

They both have halmacpi.dll as original filename. 

It's almost impossible to do a clean install of the pc's because the old pc's are from our lab, so with sofisticated programs and installations. I hope I can find the solution because an original installation will cost our more time and with no guarantee that the lab programs wil work.

Maybe I did something wrong with sysprep.
I don't understand why I should put som much in the inf file because the windows doesn't have to install anymore.

When the computer starts, I see a the windows screen for 1 second and the nhe reboots to the startup in safem ode screen.

I will try sysprep today, over and over again and I hope it will work somehow/

Thanks for the information. If you have any more info, I will appreciate it!