Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

After successfully upgrading SEPM v 12.1 RU1 into 12.1 RU1 MP1, SEPM failed to start ?

Created: 14 Sep 2012 • Updated: 18 Sep 2012 | 30 comments
This issue has been solved. See solution.

Hi,

I don't know how this could happens ?

even after restarting the server, I still unable to start the SEPM server. Here's the error in the event viewer of my Windows Server 2008 Standard 32 bit:

 

 
Log Name:      Application
Source:        semsrv
Date:          15/09/2012 12:06:40 PM
Event ID:      4096
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SEPM-VM.domain.com
Description:
The Java Virtual Machine has exited with a code of -1, the service is being stopped.
 
 
Log Name:      Application
Source:        Application Error
Date:          15/09/2012 12:08:16 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SEPM-VM.domain.com
Description:
Faulting application Smc.exe, version 11.0.6005.440, time stamp 0x4bc92841, faulting module MSVCR80.dll, version 8.0.50727.4016, time stamp 0x49cc5361, exception code 0x40000015, fault offset 0x000046b4, process id 0x494, application start time 0x01cd92e50dc101f2.
 
Any assistance is greatly appreciated.
 
Thanks !

Comments 30 CommentsJump to latest comment

John Santana's picture

from the above it said that Faulting application Smc.exe, version 11.0.6005.440 which means that was the old version ? while the current installed is v12.1 RU1 not v11 anymore.

How is this possible ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

P_K_'s picture

These are two different issues they may not be releated.

You can also try running managment server configuration wizard.

Start>Programs>Symantec endpoint protection manager>managment server configuration wizard.

MCT MCSE-2012 Symantec Technical Specialist (SCTS)

pete_4u2002's picture

the faulting application is becuase you are running SEP 11.ru6 client on the SEPM server machine. However the server is SEPM 12.1.

FOr server issue, can you pass on the scm-server-0.log from the tomcat\logs folder of SEPM?

for the faulting application can you try upgrading to 12.1 ru1 mp1?

 

Ashish-Sharma's picture

hi Check this artical

Event id 4096 Java -1 error in event viewer, SEPM service will not stay in started state. "Failed to connect to server" message during login to SEPM

http://www.symantec.com/business/support/index?page=content&id=TECH181655

 

  • Event Type: Error
  • Source: Application Error
  • Event ID: 1000
  • Description: Faulting application php-cgi.exe, version 5.3.10.0, time stamp 0x4f6121a7, faulting module php_curl.dll, version 5.3.10.0, time stamp 0x4f6121af, exception code 0xc0000005, fault offset 0x000345a3,process id 0x14fc, application start time 0x01cd506e9e93c700

Event ID 1000-The Symantec Endpoint Protection Manager Endpoint Status chart is not refreshing on Home screen after an upgrade from 12.1 RU1 to 12.1.1101.401 - Faulting application name: php-cgi.exe

http://www.symantec.com/business/support/index?page=content&id=TECH191091

Thanks In Advance

Ashish Sharma

 

 

John Santana's picture

Ashish,

As per this article: http://www.symantec.com/business/support/index?page=content&id=TECH181655

the entry is already there "scm.db.datasource=jdbc/metadatabase"

but still the "Management Server Configuration Wizard" failed to launch. and this error Event ID 4096 is logged "The Java Virtual Machine has exited with a code of -1, the service is being stopped."

While for this article: http://www.symantec.com/business/support/index?page=content&id=TECH191091 I cannotsee any Event ID 1000 in the event viewer so it is not relevant to me.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Mohan Babu's picture

Better check with the conf.properties file inside the folder

C;\Program files\Symantec\Symantec Endpoint protection Manager\Tomcat\conf

or

C;\Program files\Symantec\Symantec Endpoint protection Manager\Tomcat\etc

 

Make sure the file is not 0 bytes. If so then ur configurations for SEPM is corrupted you need to contact Symante support..

If possible upload the scm-server-o.log

Mohan Babu

moglie20@gmail.com

+91 9884382160

Your satisfaction is very important to us.If you find above information helpful or it has resolved your issue...please mark it accordingly :)

John Santana's picture

C;\Program files\Symantec\Symantec Endpoint protection Manager\Tomcat\conf\conf.properties is 4 KB or not 0 KB which means it is good.

C;\Program files\Symantec\Symantec Endpoint protection Manager\Tomcat\etc\conf.properties is 2 KB or not 0 KB which means it is good too.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

Here's the scm-server-0.log file:

 

2012-09-15 13:24:45.962 THREAD 1 SEVERE: ================== Server Environment ===================

2012-09-15 13:24:45.962 THREAD 1 SEVERE: os.name = Windows Server 2008

2012-09-15 13:24:45.962 THREAD 1 SEVERE: os.version = 6.0

2012-09-15 13:24:45.962 THREAD 1 SEVERE: os.arch = x86

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.version = 1.6.0_26

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.vendor = Sun Microsystems Inc.

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.vm.name = Java HotSpot(TM) Server VM

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.vm.version = 20.6-b01

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jre

2012-09-15 13:24:45.962 THREAD 1 SEVERE: catalina.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat

2012-09-15 13:24:45.962 THREAD 1 SEVERE: java.user = null

2012-09-15 13:24:45.962 THREAD 1 SEVERE: user.language = en

2012-09-15 13:24:45.962 THREAD 1 SEVERE: user.country = AU

2012-09-15 13:24:45.962 THREAD 1 SEVERE: scm.server.version = 12.1.1101.401

2012-09-15 13:24:48.242 THREAD 1 SEVERE: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.

2012-09-15 13:24:48.383 THREAD 1 SEVERE:  in: com.sygate.scm.server.servlet.StartupServlet

com.sygate.scm.server.util.ScmServerError: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.

at com.sygate.scm.server.servlet.StartupServlet.verifySchemaVersion(StartupServlet.java:491)

at com.sygate.scm.server.servlet.StartupServlet.registerServer(StartupServlet.java:357)

at com.sygate.scm.server.servlet.StartupServlet.init(StartupServlet.java:137)

at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)

at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1026)

at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4421)

at org.apache.catalina.core.StandardContext.start(StandardContext.java:4734)

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)

at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:675)

at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:601)

at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)

at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)

at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)

at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)

at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)

at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)

at org.apache.catalina.core.StandardService.start(StandardService.java:525)

at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)

at org.apache.catalina.startup.Catalina.start(Catalina.java:595)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
 

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

and when I execute the Database Upgrade wizard, I got this error:

 

---------------------------

Java Virtual Machine Launcher

---------------------------

Could not find the main class: com.sygate.scm.install.Main. Program will exit.

---------------------------

OK   

---------------------------
 

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Ashish-Sharma's picture

hi john,

2012-09-15 13:24:48.242 THREAD 1 SEVERE: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.

2012-09-15 13:24:48.383 THREAD 1 SEVERE:  in: com.sygate.scm.server.servlet.StartupServlet

com.sygate.scm.server.util.ScmServerError: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.

 

 Run upgrade.bat wizard.

Edit####

 which will be located under "Program Files\Symantec\Symantec Endpoint Protection Manager\Bin"

Thanks In Advance

Ashish Sharma

 

 

pete_4u2002's picture

whats the SEPM version installed on the srever?

did you run the upgrade.bat from the this location "\Symantec\Symantec Endpoint Protection Manager\bin\upgrade.bat'

John Santana's picture

Ashish, nothing happens when I execute thaqt batch file, it was just a flash of command prompt window ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Ashish-Sharma's picture

Hi,

try to repaire SEPM Add/remove program or installation DVD setup.

Check this thread

https://www-secure.symantec.com/connect/forums/cant-log-sep-manager

Thanks In Advance

Ashish Sharma

 

 

John Santana's picture

Well, I have repair the installation of this SEPM server and then after I click on the FInish button, I still got this error:

 

---------------------------
Java Virtual Machine Launcher
---------------------------
Could not find the main class: com.sygate.scm.install.Main. Program will exit.
---------------------------
OK   
---------------------------
 

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

Yes I have Pete, by using the Database backup wizard.

It has generated 3.6 GB of Zip files already.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

Ashish,

I have disabled the UAC and then performing the reboot, but somehow it doesn't work still ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Ashish-Sharma's picture

Please try.

Check One of symantec employee comments for another thread but different SEPM version

Vikram Kumar-SAV to SEP Symantec Employee Accredited

Repair symantec Endpoint protection manager from add/remove programs first 

Once done run upgrade.bat from

program files\Symantec\symantec endpoint protection manager\bin\upgrade.bat

 

https://www-secure.symantec.com/connect/forums/upgrade-1106-mp1-failed-issues

 

Thanks In Advance

Ashish Sharma

 

 

John Santana's picture

Yes I ahve execute the upgrade.bat from double clicking or even from the command prompt but somehow it failed to execute (got nothing than blank black prompt).

 

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

Here's the error message thatI received, I have also tried to run the Upgrade WIzard from the start menut but it doesn't show up anything ?

SEPMError.JPG

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Ashish-Sharma's picture

hi John,

Do you have check this artical..

Event id 4096 Java -1 error in event viewer, SEPM service will not stay in started state. "Failed to connect to server" message during login to SEPM

http://www.symantec.com/business/support/index?page=content&id=TECH181655

 

The Symantec Endpoint Protection Manager Endpoint Status chart is not refreshing on Home screen after an upgrade from 12.1 RU1 to 12.1.1101.401 - Faulting application name: php-cgi.exe

http://www.symantec.com/business/support/index?page=content&id=TECH191091

Thanks In Advance

Ashish Sharma

 

 

Ashish-Sharma's picture

HI John,

We have try all of thing but we can't received any solution.

This is your last option You will be install fresh SEPM.

Symantec Endpoint Protection 12.1: Best Practices for Disaster Recovery with the Symantec Endpoint Protection Manager

http://www.symantec.com/docs/TECH160736

but first you can raised Support ticket

Contact Symantec Customer Care on 

http://www.symantec.com/support/assistance_care.jsp

OR 

Technical Support

http://www.symantec.com/business/support/contact_techsupp_static.jsp

Please contact Symantec Technical Support via the support phone numbers listed below

Regional Support Telephone Numbers:
United States: 800-342-0652 (407-357-7600 from outside the United States)
Australia: 1300 365510 (+61 2 8220 7111 from outside Australia)
United Kingdom: +44 (0) 870 606 6000
Additional contact numbers: http://www.symantec.com/business/support/contact_techsupp_static.jsp   India: Toll-Free 000 800 4401 456 directly                                                      

Thanks In Advance

Ashish Sharma

 

 

John Santana's picture

No worries Ashish,

I still appreciate your help, now I have already resolve the issue and share the solution here wih all of you.

Hope this can be a good help.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

John Santana's picture

Yes I have Pete,

and so far the solution is very simple cheeky, I wasn't thinking about this before, 

go to C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\webapps\ROOT\clientpkg, install the jre-6u31-windows-i586.exe file into the default directory and then go to C:\Program Files\Java\jre6, copy and paste the the lib and bin directories, then

Overwrite the lib and bin directories under C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jre

 

after that run the Management Server Configuration Wizard.

That seems to fixed the issue.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

SOLUTION
Ashish-Sharma's picture

ohhhhhhhh,

You have already fixed the issue .

It's sound good.

Thanks In Advance

Ashish Sharma

 

 

John Santana's picture

Yeah, finally man, it's been a long time already with the after hours troubleshooting :-)

glad that it is finished now.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.