Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

After upgrading to 7.1 media hosts becomes offline

Created: 08 Mar 2012 • Updated: 29 Mar 2012 | 4 comments
This issue has been solved. See solution.

Hi,

We have 1 master and 3 media server in our setup.We have upgraded netbackup from 6.5.6 to 7.1. Before upgrading media hosts were deactivated. After upgrading netbackup single media hosts unable to activate. While doing activation its become OFFLINE. could you help me to resolve the issue. While trying to connect from master at host properties, its ending with error code 46.

Comments 4 CommentsJump to latest comment

Mark_Solutions's picture

This could be a fully qualified domain name issue

If it does not already exist create the netbackup\logs\bpcd\ folder on the media servers and try to connect again so that we can see what is logged

You may need to add or edit the hosts files on the Master and Media Server to ensure that short or FQDN are specified

Post the bpcd logs so that we can see what is happening

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

I wonder if this might be causing your problem?

http://www.symantec.com/docs/TECH159765

Host file entries are not being used after upgrading to NetBackup 7.0.1

Cause
To support IPv6 (in NetBackup 7.1), NetBackup 7.0.1+ has changed from using the gethostbyname API to using the getaddrinfo API. On some platforms (see above), the name services switch database that determines gethostbyname behavior ('hosts') is different from that of getaddrinfo ('ipnodes').

Solution
For the hostname lookup override to work correctly in NetBackup 7.0.1+, the user must configure 'files' to have highest precedence for 'ipnodes', similar to 'hosts', in the /etc/nsswitch.conf.

        hosts:          files <other name services>
        ipnodes:        files <other name services>

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Taqadus Rehman's picture

When EMM doesnt receives connection from media server, there are possibilities for EMM to show Media server as OFFLINE.

  1. Stop the Netbackup service
  2. Stop PBX - "/opt/VRTSpbx/bin/vxpbx_exchanged stop"
  3. Start PBX - "/opt/VRTSpbx/bin/vxpbx_exchanged start"
  4. Start the Netbackup service.

- Also check the bp.conf file.

- Try running 'vmoprcmd -activate_host -h <media server name>' on the master server.

- Kindly post o/p of below command

<install path>\verits\netbackup\bin\admincmd#nbemmcmd -getemmserver

if NBU4 shown offline in above command then check connectivity between master & NBU (put FQDN in to host file)

Regards, Taqadus Rehman

mubarack.s's picture

Hi,

Thanks you all. Its is pure realted to FQDS. In netbackup 7.1 its started to read /e/hosts file instead of domain server. We have removed the master server entries from /etc/hosts and reloaded the netbackup. Its working fine. Sorry for the late reply.

 

 Thanks and regards,

Mubarack.S