Video Screencast Help

Agents crashing when selecting Software Update tab

Created: 15 Feb 2011 • Updated: 25 Feb 2011 | 5 comments
This issue has been solved. See solution.

Several of our agents are crashing when I select the sofware update tab. Incidentally, they are win2003 vmware servers.

The message reads "Altiris Agent has encountered a problem and needs to close." The info link shows an Error signature: EventType: BEX P1:AeXAgentUIHost.exe P4: PatchMgmtAgentsUI.dll. There is a dump file under my login profile.

I have ran a clean uninstall of the agent removing program file folders and altiris registry keys. I pulled the agent down from our NS and watched all the plugins reinstall.

Any clue?

Comments 5 CommentsJump to latest comment

Ludovic Ferre's picture

If they contain more information that you provided, of course ^_^.

Normally the tab are registers as COM components and in the agent under sheets if I'm not mistaken. You may want to unregister and re-register next time around, just to see if the issue is limited to the UI code.

 

Update: to register the agent page you need to run "regsvr32 /u <path_to_agent_dll>". To register just do "regsvr32 <path_to_agent_dll>".

I am currently off-net, on a retreat of some kind. I'll be back real soon, and you sure will hear from me then ;-).

Ludovic FERRÉ
Principal Remote Product Specialist
Symantec

rpleasan's picture

Thanks Ludovic,

I unregistered and re-registered both the patchmgmtagents.dll and patchmgmtagentsui.dll but the agent still crashes and closes when I select Software Update tab. I even copied the .dll files from a working agent server to no resolve. I even noticed that the AeXNSAgent.exe is running although the AeXAgentUIHost.exe has closed. I am able to still manage the agent using the agent diagnostic program.

 

Altiris Agent - Error signaure

EventType: BEX P1: AeXagentUIHost.exe P2: 7.0.74.36 P3: 4bfe558 P4: PatchMgmtAgentsUI.dll P5: 7.0.4312 P6: 4c766a40 P7: 00021237 P8 : c0000409 P9: 0000000

The following files will be included in this error report:

 

Manifest.txt:

Server=watson.microsoft.com
UI LCID=1033
Flags=1672018
Brand=WINDOWS
TitleName=Altiris Agent
DigPidRegPath=HKLM\Software\Microsoft\Windows NT\CurrentVersion\DigitalProductId
ErrorText=If you were in the middle of something, the information you were working on might be lost.
Stage1URL=/StageOne/Generic/BEX/AeXAgentUIHost_exe/7_0_1641_8641/4c92d2fa/PatchMgmtAgentsUI_dll/7_0_0_4409/4d07ac84/000212d7/c0000409/00000000.htm
Stage2URL=/dw/GenericTwo.ASP?EventType=BEX&P1=AeXAgentUIHost.exe&P2=7.0.1641.8641&P3=4c92d2fa&P4=PatchMgmtAgentsUI.dll&P5=7.0.0.4409&P6=4d07ac84&P7=000212d7&P8=c0000409&P9=00000000
DataFiles=C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00\AeXAgentUIHost.exe.mdmp|C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00\appcompat.txt
Heap=C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00\AeXAgentUIHost.exe.hdmp
ErrorSubPath=Generic\BEX\AeXAgentUIHost.exe\7.0.1641.8641\4c92d2fa\PatchMgmtAgentsUI.dll\7.0.0.4409\4d07ac84\000212d7\c0000409\00000000
DirectoryDelete=C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00
 

Appcompat:

    <MATCHING_FILE NAME="Agents\PatchMgmtAgent\PatchMgmtAgentsUI.dll" SIZE="647168" CHECKSUM="0xA3E59EC2" BIN_FILE_VERSION="7.0.0.4409" BIN_PRODUCT_VERSION="7.0.0.4409" PRODUCT_VERSION="7.0.4409.0" FILE_DESCRIPTION="Altiris Patch Management Agents UI" COMPANY_NAME="Altiris" PRODUCT_NAME="Altiris Patch Management Core Assembly" FILE_VERSION="7.0.4409.0" ORIGINAL_FILENAME="PatchMgmtAgentsUI.dll" INTERNAL_NAME="PatchMgmtAgentsUI" LEGAL_COPYRIGHT="Copyright (c) 1998-2006, Altiris, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xA6CD3" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="7.0.0.4409" UPTO_BIN_PRODUCT_VERSION="7.0.0.4409" LINK_DATE="12/14/2010 17:42:28" UPTO_LINK_DATE="12/14/2010 17:42:28" VER_LANGUAGE="English (United States) [0x409]" />

gshpakov's picture

Hello,

could you please provide additional information that could help to understand what is happening?

 

  1. Versions of the Symantec Management Platform and Patch Management Solution.
  2. Versions of Altiris Agent and Software Update Plug-in - from the clients where the problem DOES and DOES NOT reproduce.
    Screenshots from “Altiris agent settings” menu of the tray menu of AA icon are OK.
  3. Entire Registry dump of HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Altiris Agent  from clients where problem reproduces.
  4. Policy XML from client where the problem reproduces at the moment it reproduces.
    It can be found in the directory "C:\Program Files\ALTIRIS\Altiris Agent\Client Policies".
  5. Crash dump files of AeXAgentUIHost.exe (if any).
    They usually can be found in temporary locations, e.g.
    C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00\AeXAgentUIHost.exe.mdmp
    C:\DOCUME~1\R\LOCALS~1\Temp\WER594f.dir00\AeXAgentUIHost.exe.hdmp

Thanks in advance,
Grigory.

KSchroeder's picture

You may want to try applying the hotfixes in this article as well:

http://www.symantec.com/docs/HOWTO36013

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

rpleasan's picture

This problem has been resolved.

We enabled multiple schedules for the Default Software Update policy. After removing all but one, and updating the agent, our problem was resolved.

Thanks all

SOLUTION