Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Allow delete in EV 10 to one specific user - failed

Created: 13 Feb 2013 • Updated: 14 Feb 2013 | 7 comments
Sarah.Seftel's picture
This issue has been solved. See solution.

Hi,

I created a provisioning group for one dedicated user that will have permissions to delete from his archive.

copied the desktop policy and allowed deletion of both shortcut and email.

also allowed deletion in site settings, and in the retention category.
moved the group to rank 1 in provisioning, checked provisioning report - user got the new policy.

added webapp.ini with :

 

ISDeleteButton=1
ArchiveExplorerDelete=1
 
iisreset done
 
Cleared IE cache, synced mailbox.
opened archive explorer - deleted item, got "item deleted"
refreshed the page - item is back again, as if it was never deleted...
 
Anything that I missed?
 
Sarah.
 
 

Comments 7 CommentsJump to latest comment

Bruce Crankshaw2's picture

What Storage device are you using as this can still prevent deletion, an example of this is a Centera running in Governance mode?

Sarah.Seftel's picture

No delete restrictions from storage side for sure...

JesusWept3's picture

ArchiveExplorer will "delete" the item, but can come back from a refresh because it simply hasn't been deleted out of the index yet, your best bet is to first go to the users archive and see if the Deleted Items tab shows they have items in their dumpster or not.

If it shows more than 0, then you know items are actually being deleted and that its an indexing issue and not a policy or configuration issue.

Sarah.Seftel's picture

Hi Jesus smiley

 

we waited 5 minutes and it was still on 0

but I will connect to the customer tomorrow and double check again if items were deleted or not...

 

Thanks.

 

JesusWept3's picture

it should be instantaneous
So i guess the questions are

1. Does the site setting allow users to delete?
2. does the retention category allow for deletes?
3. After the provisioning ran and it updated the users provisioning group, did you sync their mailbox?

Also when they "deleted" the item, they were logged in to their own account when they attempted to delete right?

best bet is if they are synced, provisioned, the site policy allows deletes and the retention allows deletes, to dtrace W3WP, AgentClientBroker and Storage Delete and see what happens when the user attempts to delete the item.

JesusWept3's picture

oh one other thing that i forgot to mention, that count will remain at 0 if the dumpster is disabled, so it might not indicate whether items are being deleted or not, only if you enable the dumpster will it start to increment

You can check the journalDelete table to see if any items are stored there to confirm whether deletes are taking place or not

SOLUTION
Sarah.Seftel's picture

I connected to the customer now and this time he had items in his deleted items tab.
weird, but it looks like it just took some time to refresh or something like this.

We tried to deleted again, this time item count in seleted tab changed instantly!

It was probabely slow indexing issue...

Thanks!