Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Altiris 7.1 Deploy Image Task not Sysprepping

Created: 18 Sep 2012 • Updated: 21 Sep 2012 | 16 comments
This issue has been solved. See solution.

In 6.9, I had a Deploy Image task that contained a series of .img files.  I could run this task on any machine and it would image Windows 7 onto it.  Not only that, but the image was sysprepped, so when it finished imaging, it was ready to login with the Administrator account already enabled.

In 7.1, when I run a Deploy Image task on a machine, it images to Windows  7 just like it should, but when it is finished and I reboot to production, it acts like it has not been sysprepped.  It asks for an account name, password and product key, which should not be happening.  I would like it to be like it was in 6.1, where this one Deploy Image task brought the actual sysprepped image across, with the Administrator account enabled.

Any thoughts or suggestions on this?  I am not sure if I am missing a step here.

Thank you.

Comments 16 CommentsJump to latest comment

Sachin_Joshi5's picture

Hello,

I have not used DS 6.9 and not sure how image is being syspreped there.

But in 7.1 & onwards there is a separate task 'Prepare for Image Capture' which essentially need to be executed on client before running create disk image task. It is applicable for both windows & Linux.

For Windows, user has to specify: OS type, Product key, user credentials & boot method.

You have to recreate a sysperped image again by running 'prepare for image capture' & then use that to deploy across clients.

I hope this will help.

Thanks,
Sachin

If this suggestion helps to resolve your issue then please mark it as Solution.

 

ianatkin's picture

Sysprep is the same no matter what deployment tool you use. What matters with Windows 7 is,

  1. Whether your agents are in image, or not
  2. The xml you sysprep your image with
  3. The xml you deliver with your syspreped image

The problem with delivering 6.9 images with 7.x appears when you have agents in the image. The 7.x agents are  completely different beasts to their 6.x cousins, and do not upgrade terribly well.  If you therefore have the 6.x agents installed  in your image (rather than through the unattend.xml) then you will have to re-sysprep.

If your don't have the agents in your image, then I would look to your unattend xml files. It is likely something is amiss here. You can post your XML here if you'd like some help deciphering what might be going wrong.

Kind Regards,
Ian./

 

 

Ian Atkin, IT Services, Oxford University, UK

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads

boonet's picture

Thank you for the information, ianatkin.

Would I have to re-sysprep the entire image, or could I just remove the 6.9 agent, install the 7.1 agent, and recapture?

andykn101's picture

If you look at the log files in

  • C:\windows\Panther
  • C:\Windows\System32\Sysprep\Panther
  • C:\Windows\Panther\UnattendGC

you may find sysprep has run but, like Ian says, doesn't have an unattend xml file with sections for the passes involved, specialize, auditSystem and auditUser.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

boonet's picture

I ran the Prepare for Image Capture ask, which seemed to work.  When it rebooted, applied system settings, etc, I was prompted with the Administrator account.  However, when I tried logging into it, it said that the account had been disabled.  Is this normal?

andykn101's picture

Disabling the built in Local Adminsitrator account is the default for Windows 7 sysprep. Normally you'd join a domain and log in with a domain account.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

boonet's picture

Here are the steps I have taken so far:

- In 6.9, I deployed an image created in 6.9 to a laptop.  When it was finished, I was able to log in as the administrator normally.  I removed the 6.9 agent from the laptop and made sure that the 7.1 agent was installed.

- I ran the Prepare for Image Capture task in 7.1 on the same laptop.  It seemed to run fine, as it came back to apply system settings, check video performance, etc.  When it came back to the login screen, the Administrator account was there.  However, when I tried logging into it, it reported that the account was disabled.

- I am now running the Capture Image Task.  Once this is done, I will try to create a Deploy Image task and see if I can image another machine with the freshly created image.  Ideally, I will be able to login to the machine with the Administrator account.

boonet's picture

Here is an update on what I have done:

I set up a laptop with the 7.1 agent/software, etc. and ran the Prepare for Image Capture task.  

After this, it PXE booted and I ran the Capture Image task

When this was finished, it rebooted, applied some settings, and then when I logged into Windows, Sysprep opened.

I then took a PC and PXE booted, and am currently running a "Deploy image" task with the image that I just captured.  I am curious as to what may happen here.

Are there any additional steps that I should have taken in order to make this work better?

andykn101's picture

You need to add a Configuration Task to get it to join the domain otherwise you won't be able to log in because the default for Windows 7 is to disable the built in Local Administrator account.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

ianatkin's picture

As Andy says, the default windows behaviour for Windows 7 is to disable the local administrator account. In my XML for windows 7 I always create a new local administrator account, or alternatively you could have your XML enable the disabled admin account.

As I said before, it would be useful to see the unattend XML files you are deploying your image with.

Kind Regards,
Ian./

Ian Atkin, IT Services, Oxford University, UK

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads

boonet's picture

I have a custom unattend file that enables the Administrator account.

I got the machine to image successfully.  However, after my Prepare for Image Capture task, it PXE booted.  That is when I sent the Capture Image.

Now when I drop that image onto a machine, it will Check Video for Performance, Install Devices for several minutes before it takes me to the login screen, where I am able to login as the Administrator.  However, when the Desktop loads, Sysprep pops up and asks what System Cleanup Action I want to perform and gives me Shutdown options.  I thought this part should have been done within the Prepare for Image Capture task?

 

Did I miss a step?

ianatkin's picture

/OK -this is certainly odd. The "Prepare Image For Capture" task puts the Symantec Management Agent into a clonable state, runs sysprep and then reboots the machine.

From the fact you are doing a hardware detection (and of course have been suffering the disabling of the local admin account!!) says to us that sysprep is indeed being run. Your steps are therefore fine (from what you report here).

Can you provide your XML here so we can take a look.

Kind Regards,
Ian./

Ian Atkin, IT Services, Oxford University, UK

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads

boonet's picture

 

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>en-US</UILanguage>
            </SetupUILanguage>
            <InputLocale>en-US</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
            <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <DiskConfiguration>
                <Disk wcm:action="add">
                    <CreatePartitions>
                        <CreatePartition wcm:action="add">
                            <Order>1</Order>
                            <Size>300</Size>
                            <Type>Primary</Type>
                        </CreatePartition>
                        <CreatePartition wcm:action="add">
                            <Order>2</Order>
                            <Extend>true</Extend>
                            <Type>Primary</Type>
                        </CreatePartition>
                    </CreatePartitions>
                    <ModifyPartitions>
                        <ModifyPartition wcm:action="add">
                            <Order>1</Order>
                            <Active>true</Active>
                            <Format>NTFS</Format>
                            <Label>System</Label>
                            <PartitionID>1</PartitionID>
                        </ModifyPartition>
                        <ModifyPartition wcm:action="add">
                            <Order>2</Order>
                            <Format>NTFS</Format>
                            <Label>Windows</Label>
                            <PartitionID>2</PartitionID>
                        </ModifyPartition>
                    </ModifyPartitions>
                    <DiskID>0</DiskID>
                    <WillWipeDisk>true</WillWipeDisk>
                </Disk>
                <WillShowUI>OnError</WillShowUI>
            </DiskConfiguration>
            <ImageInstall>
                <OSImage>
                    <InstallTo>
                        <PartitionID>2</PartitionID>
                        <DiskID>0</DiskID>
                    </InstallTo>
                    <InstallToAvailablePartition>false</InstallToAvailablePartition>
                    <WillShowUI>OnError</WillShowUI>
                </OSImage>
            </ImageInstall>
            <UserData>
                <ProductKey>
                    <WillShowUI>OnError</WillShowUI>
                </ProductKey>
                <AcceptEula>true</AcceptEula>
                <Organization>&quot;DB&quot;</Organization>
                <FullName>&quot;DB&quot;</FullName>
            </UserData>
        </component>
    </settings>
    <settings pass="offlineServicing">
        <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <EnableLUA>false</EnableLUA>
        </component>
        <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <DriverPaths>
                <PathAndCredentials wcm:action="add" wcm:keyValue="628725cd">
                    <Credentials>
                        <Domain>db</Domain>
                        <Password>altirisdeploy</Password>
                        <Username>deploy</Username>
                    </Credentials>
                    <Path>\\dbgbat1\express\Deploy\Distribution_Share\Out-of-Box Drivers</Path>
                </PathAndCredentials>
            </DriverPaths>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Order>1</Order>
                    <Path>net user administrator /active:yes</Path>
                </RunSynchronousCommand>
            </RunSynchronous>
        </component>
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <CompanyName>DB</CompanyName>
            <DisableAccelerators>true</DisableAccelerators>
            <DisableFirstRunWizard>true</DisableFirstRunWizard>
            <DisableOOBAccelerators>true</DisableOOBAccelerators>
            <Home_Page>www.db.com</Home_Page>
            <LocalIntranetSites>inside.db.com</LocalIntranetSites>
            <ShowInformationBar>true</ShowInformationBar>
            <ShowMenuBar>true</ShowMenuBar>
            <TrustedSites>inside.db.com</TrustedSites>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <AutoLogon>
                <Password>
                    <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>
                    <PlainText>false</PlainText>
                </Password>
                <Enabled>true</Enabled>
                <LogonCount>10</LogonCount>
                <Username>Administrator</Username>
            </AutoLogon>
            <ShowWindowsLive>false</ShowWindowsLive>
            <TimeZone>Central Standard Time</TimeZone>
        </component>
        <component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <fDenyTSConnections>false</fDenyTSConnections>
        </component>
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Identification>
                <Credentials>
                    <Domain>b.com</Domain>
                    <Password>altirisdeploy</Password>
                    <Username>deploy</Username>
                </Credentials>
                <JoinDomain>b.com</JoinDomain>
            </Identification>
        </component>
        <component name="Networking-MPSSVC-Svc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <FirewallGroups>
                <FirewallGroup wcm:action="add" wcm:keyValue="1">
                    <Active>true</Active>
                    <Group>Remote Desktop</Group>
                    <Profile>all</Profile>
                </FirewallGroup>
            </FirewallGroups>
            <DomainProfile_EnableFirewall>false</DomainProfile_EnableFirewall>
            <PrivateProfile_EnableFirewall>false</PrivateProfile_EnableFirewall>
            <PublicProfile_EnableFirewall>false</PublicProfile_EnableFirewall>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-US</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
            <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <AutoLogon>
                <Password>
                    <Value>VAB1AHIAbgAwAFYARQBSAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                    <PlainText>false</PlainText>
                </Password>
                <Enabled>true</Enabled>
                <LogonCount>10</LogonCount>
                <Username>administrator</Username>
            </AutoLogon>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                <NetworkLocation>Work</NetworkLocation>
                <ProtectYourPC>3</ProtectYourPC>
            </OOBE>
            <UserAccounts>
                <AdministratorPassword>
                    <Value>VAB1AHIAbgAwAFYARQBSAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>
                    <PlainText>false</PlainText>
                </AdministratorPassword>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value>VAB1AHIAbgAwAFYARQBSAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                            <PlainText>false</PlainText>
                        </Password>
                        <Description>Local Administrator</Description>
                        <DisplayName>Administrator</DisplayName>
                        <Group>Administrators</Group>
                        <Name>Administrator</Name>
                    </LocalAccount>
                </LocalAccounts>
                <DomainAccounts>
                    <DomainAccountList wcm:action="add">
                        <Domain>b.com</Domain>
                        <DomainAccount wcm:action="add">
                            <Group>administrators</Group>
                            <Name>ISWorkstationSupport</Name>
                        </DomainAccount>
                    </DomainAccountList>
                </DomainAccounts>
            </UserAccounts>
            <RegisteredOrganization>DB</RegisteredOrganization>
            <RegisteredOwner>DB</RegisteredOwner>
            <TimeZone>Central Standard Time</TimeZone>
            <ShowWindowsLive>false</ShowWindowsLive>
        </component>
        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Reseal>
                <Mode>Audit</Mode>
            </Reseal>
        </component>
    </settings>
    <settings pass="auditSystem">
        <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <DriverPaths>
                <PathAndCredentials wcm:action="add" wcm:keyValue="628725cd">
                    <Credentials>
                        <Domain>db</Domain>
                        <Password>altirisdeploy</Password>
                        <Username>deploy</Username>
                    </Credentials>
                    <Path>\\dbgbat1\express\Deploy\Distribution_Share\Out-of-Box Drivers</Path>
                </PathAndCredentials>
            </DriverPaths>
        </component>
    </settings>
    <settings pass="generalize">
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipRearm>1</SkipRearm>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim:d:/data/isos/win7_x64_ent/sources/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
 
ianatkin's picture

Have you been doing anything in Audit Mode with this image? One possible explaination for this is that you have been using audit mode at some point in this process and are then using Altiris to "prepare" the machine too.

You see, Windows 7 automatically runs sysprep when you start the operating system in audit mode.

 

Ian Atkin, IT Services, Oxford University, UK

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads

boonet's picture

It looks as if the unattend file was to blame.  Thank you for your help guys.

boonet's picture

More specifically, the unattend file located in:  NSCap\bin\Win32\X86\Deployment

Needed to be overwritten with the correct file.  This is the unattend that the Prepare for Image Capture task uses.

SOLUTION