Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Altiris 7.1 Deploy Workspace Virtualization

Created: 15 Aug 2012 • Updated: 07 Sep 2012 | 9 comments
This issue has been solved. See solution.

Hi,

i Deploy Workspace Virtualization from my Altiris NS (running 7.1) and I cannot find the Admin Tool installed.

I can only find the the following files in c:\Program Files\symantec\Workspace Virtualization

  • SVSCmd.exe
  • SvsWmi.dll
  • SvsWmi.mof
  • SMV.Xpf.manifest
  • UIUtils.dll

Please help.

Comments 9 CommentsJump to latest comment

andykn101's picture

To deploy the Admin tools with the SWV agent the only way I could get it to work was to run the install twice, once to install the agent and then again straight afterwards to install the Admin tools. Using DS 6.9 "Distribute Software" task the additional Windows Installer command line switches are :

REBOOT=ReallySuppress PRODUCT_KEY=xxxxx-xxxxx-xxxxx-xxxxx ALTIRIS_NS=1 ADDLOCAL=Complete,SDK,SVS_Admin,FSLRDR,Altiris_NS /l*v SWVv615126.log

PRODUCT_KEY=xxxxx-xxxxx-xxxxx-xxxxx ALTIRIS_NS=1 ADDLOCAL=SDK,SVS_Admin /l*v SWVv615126b.log

 

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

isaacho's picture

Thanks.

In my Altiris NS 7.1, there is a predefined software delivery task.
it seems that I can only install the SWV from it.

The package seems doesn't include the Admin Tool.
Where can I find it?

andykn101's picture

It's the same package, just with different command lines. Just run the install again with the second command line I gave you.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Zac H's picture

You could also edit the original install package to install the admin tools, but I doubt you want it installed for everyone...

isaacho's picture

thanks.
from my understanding, admin tool is used for packaging software for SWV, so I only plan to install admin tool for responsible persons. Am my concept correct? :)

andykn101's picture

It can also be used to turn layers on and off. But usually for normal users you'd do that remotely.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

isaacho's picture

I tried to modify the default install command but seems a little bit difference from the suggested parameters.

here is what i have
Symantec_Workspace_Virtualization_x64.exe /s /e SWV.ADDLOCAL=Altiris_NS

 

Please help. :)

isaacho's picture

I finally go to Add/Remove Program to install the Admin Tool.

Thanks.

TOM_B's picture

I deploy it using this and it seems to work.

 

Symantec_Workspace_Virtualization_x64.exe /s SWV.ADDLOCAL=Altiris_NS,SVS_Admin

Symantec_Workspace_Virtualization_x32.exe /s SWV.ADDLOCAL=Altiris_NS,SVS_Admin

SOLUTION