Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Altiris 7.1 image deployment is ignoring the unattend file

Created: 07 Aug 2012 | 6 comments
r1s1000rr's picture

I am attempting to deploy an Windows Server 2008 Standard image to some test systems.  The image deployment goes fine, but it seems like my sysprep configuration file does not get applied.  The computers are pre-defined by MAC and with a computername.  The answer file has @compName specified for ComputerName, and if I get on the system after it's done dropping the image, I can see that he unattend.xml file it puts in x: has the correct coputername.  Once the sysprep is done though, a random Win-blah name is there, and the auto-login setting doesn't take.  To simplify testing, I used the default system-generated answer file option, and it still doesn't take the predefined computer name.  There is nothing at all in c:\windows\panther\setuperr.log. 

 

Any thoughts on how to even go about troubleshooting this one, or what may be causing it? 

Comments 6 CommentsJump to latest comment

yogeshsadhu's picture

In the panther folder you should also see unattended file which it has applied , check this file;

Other wise if you see correct computer name in unattended file at x: then there should not be a problem ; But just unattended file at Panther folder.

Yogesh Sadhu.

If you feel your issue has been addressed,please use the "Mark as Solution" link for the relevant thread.

r1s1000rr's picture

The unattend.xml file that is in c:\windows\panther post-deployment is completely different then the one that was shown in x: right after the image deployment.  Things defined in that one don't seem to be on the system either (i.e. specified user accounts don't actually exist on the system).  It really

Oddly enough creating the base image from a different system (a VM actually) but using the same capture and deploy jobs loooks to work.  It just seems to be with a standard install from DVD that is captured from a physical server that I run into the issue of the specified unattend not being applied at all.  Even if I select to have Altiris generate the sysprep file, it still doesn't seem to get successfully applied.

dries_point's picture

we have exactly the same problem, but only on a site server,   for our main site this is working fine.

we have not built the image on a vm. 

Thomas Baird's picture

Justin, we'd need more specific information about your issue.  This is a very specific issue, and unless yours is exactly the same, you should probably start a new thread with details.

 

The short answer to this is that we need to look at the unattend file that is in the ^systemdrive%\windows\panther folder to see what was trying to happen, what DID happen, etc.

IF you have a custom unattend, try without it first.

IF the system is predefined, ensure that it's actually picking up a job assigned to it and not an initial deployment job.

 

There are a lot of possibles, so the best way to get an answer is to give us your specifics.

 

Thanks, and GL!

Thomas Baird
Enthusiast for making things better!

 

dries_point's picture

we made some mistakes in the configuration. after reconfig everthing worked.   but these mistakes were very specific, and are for sure not going to apply to everybody. ( like Thomas says)  plus i dont remember them so i cant share.