Video Screencast Help

Altiris 7.1 SP2 Virtual Machine inventory

Created: 05 Jan 2012 | 9 comments

Hi there,

 

i have deployed 7.1 SP2 hoping that we can use it for our entire ESX estate.

We have multiple vCentres each with multiple ESX hosts of various versions. Multiple firewalls control access to the ESX hosts themselves, the Altiris server will only have access to the vCentres.

I can discover the vCentre easily enough, but I cannot run an inventory task - the target for teh inventory tasks is limited to only hosts with a hypervisor installed and if I manually add a vCentre server into the list it fails to run. Has anyone managed to get the inventory task to run from only vCentre ?? Is there any documentation on this as the VMM user guide only lists accessing the ESX host.

 

Many thanks,

 

Nobby Clarke

Comments 9 CommentsJump to latest comment

Joseph_Carson's picture

Hello Nobby,

Please check that the Credentials are correct within the Credential Manager for the vCenter and Hosts.  I would also suggest to contact technical support.

Do you also have any errors in the logs that occur during the Inventory Task?

Kind Regards,

Joseph_Carson's picture

Hello Nobby,

Just checking on any progress?

Kind Regards,

Nobby Clarke's picture

Sorry, we got sidetracked on other issues.

 

Credentials are all correct otherwise discovery would not work. The logs don't show anything as I cannot actually configure the inventory task to do what I need - the inventory task restricts itself to machines which have hypervisor installed. Clearly a vCentre does not have a hypervisor installed so is never available as a target for the inventory task - this is the crux of my issue.

 

regards,

 

Nobby

Nobby Clarke's picture

Joseph,

 

In this thread, https://www-secure.symantec.com/connect/forums/virtual-machine-management-solution-and-vsphere-versions you state that discovery and inventory will run against vcentre first - this is what I am trying to achieve - is there any documentation explaining how to do this??

 

regards,

 

Nobby

Joseph_Carson's picture

Hello Nobby,

The targetting of the Inventory Task should be against the ESX/ESXi host as this is the host you intend to gather the inventory from though the actual inventory task once run will run against the associated vCenter in which the host was discovered via network discovery, if you look at the vCenter/Host/Guest tree the Inventory task will run against the appropriate vCenter.

I am not sure how you did the discovery, did you discover via network or via vCenter.  Did you try running the Inventory Task targetting the Hosts and what was the results?

I would highly suggest reaching out to Technical Support as they can provide more indepth troubleshooting methods to quickly identify where the process is failing.

Kind Regards,

Joseph_Carson's picture

Please also make sure the credentials used have the correct permissions to the VI API Web Services.  

We are updating a Discovery and Inventory best practice for VMM that will provide exact details and troubleshooting tips.  I will post the link to the KB once available.

HighTower's picture

Has this guide been published yet?  If so, do you have a link?

Thanks!

@nkit's picture

Hello,

Please go through our new KB article on the Authentication/Authorization Details for Executing VMM tasks -

http://www.symantec.com/docs/TECH188201. This might help you to resolve your issues.

Thanks,

Ankit Shrivastava