Video Screencast Help

Altiris 7.5 Software portal error

Created: 18 Feb 2014 • Updated: 19 Mar 2014 | 11 comments
This issue has been solved. See solution.

We test upgraded Altiris 7.5. The software portal is available but if I want to request some software (approved) I get following page:

 Capture.JPG

The messages(warnings) in the log file are below:

<event date="02/18/2014 15:39:00.1672594 +01:00" severity="2" hostName="hostname" source="Altiris.SoftwarePortal.Web.SoftwarePortalPageBase.OnPreInit" module="w3wp.exe" process="w3wp" pid="3968" thread="1068" tickCount="99823432"><![CDATA[Requested page could not be viewed: OurFQDserverName/Altiris/SoftwarePortal/UserPortal/ApprovedSoftwareConfirmationPage.aspx?PublishedSoftwareGuid=ccc3fb45-47bc-4fe2-a7d8-b4986711c86e]]></event>

Operating Systems:

Comments 11 CommentsJump to latest comment

Igor Perevozchikov's picture

Does this happen each time when you try to request software from Software Portal page?
Such problem could appear due session timeout which is by default 60 min.

iddqd idkfa idclip

Dmitri Dragunov's picture

Hi,

 

Do you have the underscore character ("_") in the name of the NS server.

 

regards,R

Dmitri

 

Admin76's picture

Hi,

No.

NS servername = sec-npcz-2

SQL servername = sql-npcz-2

regards, Pavel

dat1017's picture

I am also having this issue, but we have 7.5 in Production and only one user is getting that error. I verified he is in the database the same as other users as well as re-installed his agent, with no luck.

Erick Fiquer's picture

 

Hello guys, the access is made by a link or using the Software Portal shortcut? 
Is tested using the shortcut, it runs a DLL to open the portal, this new version does not work well using a Web link (http://SMP-Server/Altiris/SoftwarePortal/UserPorta...). 
 
This is the command to open the portal 
C:\Windows\System32\rundll32.exe "C:\Program Files\Altiris\Altiris Agent\Agents\Software Management Solution Plugin\SoftwareManagementSolution_Agent.dll",ShowSoftwarePortal
 
SW_Portal_Link.PNG
 
SW_Portal_Atalho.PNG
SOLUTION
Admin76's picture

Thank you very much Eric for good and right tip.

Yes. When I call SW portal using .dll as above, or I used the shortcut above it works! Bingo!

Well, I have displayed the SW portal shortcuts by allowing Software Portal Plug-in Policy and use it for now.

Note: In Altiris 71 it works also when I use http://<servername>/Altiris/SoftwarePortal/UserPortal/home.aspx I can request the software (open the dialog)

So when I use the SW portal shortcut I can request software and dialog is opened succesfullyCaptureSWportal_s.jpg

BUT it is not my victory!!!

Next issue is comming. When I request the Pre-Approved software it goes only to status Open but not to wanted Approved. So not quick delivery task is generated. Neither I am not able to change this status in Administration portal. (But it shouldn't be needed)

Here is my publishing of the SW resource.

CaptureSWresource.JPG

 

When I request the same software again, it return naturally following error.

CaptureSWresourceOpened.JPG

 

Erick Fiquer's picture

Use this SQL query to check if the number reached that limit requests per user.

Portal_Settings.PNG

 

SELECT 

            [Name]
           ,[RequestID]
           ,[MachineName]
           ,[UserName]
           ,[State]
           ,[Status]
           ,[PublishingItemGuid]
           ,[RequestedDateTime]
           ,[UserSchedule]
FROM 
           vSMS_SoftwareRequestStatus
WHERE
           UserName LIKE '%Insert User Name here%'
           AND State LIKE 'Open'

Or use this report attached .xml

Portal_Report.PNG

 

AttachmentSize
List of Software Portal requests per user.xml 12.3 KB
Admin76's picture

Erick, Thanks for advice.

My second error with "open" state of the SW request has been incredibly solved by itself.

It happened most propably after SQl maintenance plan, which I have run manually, when I did special manual backup. I did nothing more and it started working.

Erick Fiquer's picture

 

Ok, I'm happy to help.
 
Do you use any Managed Software Delivery Policies? 
According to the forum, this happened in version 7.1 and will disrupt (https://www-secure.symantec.com/connect/forums/sof...
The console was updated or installed directly in version 7.5? 
Open Symantec Instalation Manager on Notification Server and check if there is any FIX correction to be applied.
Admin76's picture

The question which remains is about URL http://<servername>/Altiris/SoftwarePortal/UserPor...

- Is it supported way how to call SW portal as well and in the Altiris is bug now?

- OR it is not supported way in 7.5?

Note: In 7.1 version it worked.