Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Altiris Agent Not Installing

Created: 17 Oct 2012 | 3 comments

I am running into an issue where my Windows 7 clients will not install the Altiris Agent but my XP clients will.  My Windows 7 clients have the UAC off, Firewall is off, the Altiris Identity can view the Admin$ share from the NS and the Altiris Identity account is a member of the local admin group.

When the install begins I can see that the AeXWDInstSvc text file and AexWDInstSvc application are added to the Windows directory.  The AeXNSC.exe file is added to the Windows directory but it is only 0KB.  After a few minutes the AeXNSC.exe file disappers.  When I check my NS, I see an action of Remote Installation Finshed with a status of Failed.  This has been working for years and just stopped a few weeks ago.

I have tried to run the install using Domain Admin credentials with no success.  I have a two week old ticket open with Altiris and I have worked with 4 Enginners so far.  Does anyone have any recommendations.

Comments 3 CommentsJump to latest comment

andykn101's picture

Check the AeX... logs in the %windir% or %windir%\system32.

Check for Group policy changes at the time it stopped working or try having a PC in a test OU with GPOs blocked.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

rcostanzo's picture

The Win 7 computer is in an OU that does not have any GP's applied to it.  Here is what I see in the log file.

2012-10-18 14:00:13: Remote Installation Service build (6,0,6074,130), Notification Server build (6,0,6074,130)
2012-10-18 14:00:13: Attempting to start as service.
2012-10-18 14:00:13: Started as service.
2012-10-18 14:00:13: Parsing command arguments. Command line args: -u http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe -s oNS Server -w http://NS Server/Altiris/ -nostartmenu -notrayicon -addremove -accUserName Domain\altiris_identity -accUserPassword IM5xrY/df7YLJsshk3WoOw== -n Altiris Agent Installation Service
2012-10-18 14:00:13: Parsed command arguments.
 Source URL: http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe
 Server Name: NS Server
 NS Web: http://NS Server/Altiris/
 Install Path: (null)
 Download Chunk Size: 1024
 Download Pause Interval: 25
 Show Tray Icon: NO
 Show Start Menu: NO
 Use Proxy Preconfig: NO
 Register Diagnostics: NO
 Log Enabled: YES
 Enable "Add/Remove": YES
 Uninstall: NO
 Extra Parameters: (null)
2012-10-18 14:00:14: pdwPort is true
2012-10-18 14:00:14: urlComponents.nPort = 80
2012-10-18 14:00:14: Sending 'Checking Prerequisites: Success' message to 'http://oNS Server/Altiris/'.
2012-10-18 14:00:14: Sending progress update to the NS....
2012-10-18 14:00:14: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:00:14: Requirements check:
Required: Windows NT 4.0 Service Pack 4
Detected: Windows NT 6.1 Service Pack 1

Requirements met OK.
2012-10-18 14:00:15: pdwPort is true
2012-10-18 14:00:15: urlComponents.nPort = 80
2012-10-18 14:00:15: Sending 'Checked Prerequisites: Success' message to 'http://NS Server/Altiris/'.
2012-10-18 14:00:15: Sending progress update to the NS....
2012-10-18 14:00:15: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:00:15: pdwPort is true
2012-10-18 14:00:15: urlComponents.nPort = 80
2012-10-18 14:00:15: Sending 'Starting Download: Success' message to 'http://NS Server/Altiris/'.
2012-10-18 14:00:15: Sending progress update to the NS....
2012-10-18 14:00:15: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:00:15: pdwPort is true
2012-10-18 14:00:15: urlComponents.nPort = 80
2012-10-18 14:00:15: Resolved url http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe
2012-10-18 14:00:15: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:00:16: Unable to query 'Last Modified Time' value in registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc'. (Note: this error is expected the first time the remote install service starts.): The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 3003)

2012-10-18 14:00:16: Error moving file pointer for reading 'http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe' to 0 (80072ef0) (ASWDInstSvc.cpp line: 2084)

2012-10-18 14:00:46: pdwPort is true
2012-10-18 14:00:46: urlComponents.nPort = 80
2012-10-18 14:00:46: Resolved url http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe
2012-10-18 14:00:46: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:01:16: pdwPort is true
2012-10-18 14:01:16: urlComponents.nPort = 80
2012-10-18 14:01:16: Resolved url http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe
2012-10-18 14:01:16: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:01:46: pdwPort is true
2012-10-18 14:01:46: urlComponents.nPort = 80
2012-10-18 14:01:46: Resolved url http://NS Server/Altiris/NS/NSCap/Bin/Win32/X86/NS Client Package/AeXNSC.exe
2012-10-18 14:01:46: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:01:47: Download failed too many times. Aborting.
2012-10-18 14:01:47: pdwPort is true
2012-10-18 14:01:47: urlComponents.nPort = 80
2012-10-18 14:01:47: Sending 'Finished Download: Failed' message to 'http://NS Server/Altiris/'.
2012-10-18 14:01:47: Sending progress update to the NS....
2012-10-18 14:01:47: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:01:48: pdwPort is true
2012-10-18 14:01:48: urlComponents.nPort = 80
2012-10-18 14:01:48: Sending 'Finished Install: Failed' message to 'http://NS Server/Altiris/'.
2012-10-18 14:01:48: Sending progress update to the NS....
2012-10-18 14:01:48: Unable to read value from registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc\InternetAccessType': The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6601)

2012-10-18 14:01:48: Start cleaning the install service.
2012-10-18 14:01:49: pdwPort is true
2012-10-18 14:01:49: urlComponents.nPort = 80
2012-10-18 14:01:49: Sending 'Remote Install Finished: Failed' message to 'http://NS Server/Altiris/'.
2012-10-18 14:01:49: Sending progress update to the NS....
2012-10-18 14:01:49: Unable to open registry key 'HKLM\SOFTWARE\Altiris\AeXSWDInstSvc' to load the settings: The system cannot find the file specified. (80070002) (ASWDInstSvc.cpp line: 6597)

2012-10-18 14:01:49: Altiris Agent installation finished.

andykn101's picture

Does this give you any clues:

http://www.symantec.com/docs/TECH40392

I know you aren't using https.

Or this:

http://www.symantec.com/docs/TECH40540

When you say the OU doesn't have any GPOs, is the default domain GPO specifically blocked?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.