Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Altiris Agent v7.1 Uninstall Issues

Created: 14 Dec 2012 • Updated: 14 Dec 2012 | 5 comments
This issue has been solved. See solution.

I ran a task to uninstall the Altiris Agent on my machine from the server to test out the uninstall process.  According to my machine the uninstall was successful.  But on the server side, my machine is still listed in the "Installed Agent" list and claims the agent is still installed.  I ran the task yesterday and the agent was removed (I think) at that time.  I wanted to wait a day because sometimes the server can be a little slow at updating itself.  I've tried looking at my machine for any trace of the agent, but I can locate anything.  Why does the server still say I have the agent installed and what can I do to ensure the agent has been completely removed from my machine?

Comments 5 CommentsJump to latest comment

Andrew Bosch's picture

Yes, this is currently a known issue.  When you uninstall the Altiris Agent from a computer, it doesn't automatically update the database to let it know that it's been uninstalled (by switching IsManaged from 1 to 0).  Under your purging maintenance, you have an option to retire or delete computers after 30 days of no communication - machines that have had their agent uninstalled will get caught by this policy.

So, the uninstall process is working, it's just not being properly reflected on the server.

------------------------------------
Sr. Principal SQA Engineer
Symantec

SOLUTION
Scott W. Allen's picture

What are the plans on fixing this "known issue"?

Andrew Bosch's picture

It is fixed in 7.5.

------------------------------------
Sr. Principal SQA Engineer
Symantec

jellsworth's picture

Thanks for the clarification.  I'm getting used to working with the NS so anytime something isn't working I'm afraid I'm not doing it right.  Guess I'll just wait it out and work with this in the meantime.

jellsworth's picture

Ok 7.5 it will be fixed.  Good to know, thanks!