Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Altiris console reporting showing inaccurate data

Created: 06 Jul 2012 | 17 comments

Hello,

We are running Altiris 6.9 SP3.  I'm trying to use the console (not the deployment console, just the web based console) to show us a report of software installed.

Our company is being audited for software and we need to use Altiris to provide results.  The auditing company has given us a SQL query to run against our database to report what we have installed.  It comes up with nothing, but I know the sql database is out of date.  We changed the script to look for winword.exe and it only shows 50 results, we have at least 250.

I need to update the database with accurate information.  How do I do this? 

I was looking around in the console at reports, assets and inventory, inventory, windows, software/applications, software and found a report called "count of computers by product, version, and manufacturer.  I click on run this report and get a new window, allowing me to type in what computers I want to run it on.  By default % is in that field meaning it will run on all machines.  There is a collection field that says "all 32 bit windows computers"  If I click on the edit button next to this I just get a blank screen, no options can be changed...

I run this report and get results, but it's not up to date.  How do I make this accurate?

Also is there a way to run a report for a specific .exe or file?  Whese is this located?

I have 1 week to get this working.

Comments 17 CommentsJump to latest comment

edwimb's picture

After some digging around it looks like we don't have the altiris agent installed on all machines.  I took over for someone 6 months ago and he ran this, no idea why he wouldn't install this for everyone.

Right now he has it set to only install to one OU.  If I try to go in and modify this setting I'm presented with a blank white screen.  Could be a java error.  Anyone experienced java errors in the altiris console?

edwimb's picture

The altiris collection selector displays blank on any configuration screen.  I tried various versions of Java and got the same result.

Does anyone know how to fix the Altiris collection selector?

andykn101's picture

in the Notification area by the clock?

Have you tried local and remote consoles?

Open the log viewer and look at the log when you open the failing screen.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

edwimb's picture

The java icon appearing near the clock doesn't necessarily prove or disprove if something is using java.  Mine is there, but it's just prompting for an update.

The console I'm using is a URL.  The path is http://localhost/altiris/ns/console.aspx

I attached some screenshots.  I'm clicking on the edit button to the right of Collection: All 32-bit Windows Computers.  When I do I get the blank screen displayed below.

Nothing appears in the log.

HighTower's picture

What version of Internet Explorer are you using?  This may or may not work with IE8.  If you can, try this on IE6 or IE7.

edwimb's picture

We are all on IE8.

I had a tech send me these with no other instructions:

http://www.symantec.com/business/support/index?page=content&id=TECH42121

http://www.symantec.com/business/support/index?page=content&id=TECH17176

They may be related.  Trying to figure out how to perform these fixes...

HighTower's picture

http://www.symantec.com/business/support/index?page=content&id=TECH138200

Do you have IE8 installed on the Notification Server itself?

You can try to install the ActiveX controls from the CAB file installer.  This might work, but I never was able to figure out why some machines worked properly with IE8 and others didn't. 

\\NS6Server\NSCap\Bin\Win32\X86\NS CAB Installer Package\AltirisNSCABInstaller.exe

edwimb's picture

Yes IE8 is running on the notification server itself.  Do I need to uninstall this?

Would I run these Active X Controls on the server or my test client with IE7?  What will these do?

edwimb's picture

I uninstalled IE8 on my test machine bringint it down to IE7.

I connected to the console and got the following error when I edit the section I mentioned:

HighTower's picture

How about accessing that server by name instead of by IP?  Or, adding that IP address to your Intranet or Trusted Sites zone in Internet Explorer?

edwimb's picture

I just tried it by name instead of IP and I got the blank white screen again.

HighTower's picture

As a workaround to satisfy your agent deployment requirements why not use your DS to install the NS agents?

edwimb's picture

My DS currently installs the 6.9 agents. 

The new NS I created runs 7.1.  I assume I need a 7.1 agent to connect to the 7.1 NS, no?

If I install the 7.1 agent on a client, the 6.9 agent doesn't work.

HighTower's picture

Altiris 6.9 is Deployment Solution.  I had this in place alongside Altiris NS 6.0 SP3.  I replaced my NS with Altiris 7.1SP2.  I still have my DS environment.

The screenshots you're showing are for Altiris NS 6.0 SP3.

Do you have a 6.9 DS in place?  If so, it's a completely different product than Notification Server or Symantec Management Platform and can run independently and the agents do not interfere with each other.

Is your NS6 box 2003?  Do you still have IE6 or IE7 on it?  I've found that on some machines, once I install IE8 and then downgrade the NS6 console still won't work properly.

edwimb's picture

I have one server running 6.9 DS as well as NS 6.0 SP3.  I created another server a few weeks ago that runs Altiris Asset Management Suite 7.1 SP2.  The intent was to just use 7.1 SP2 for reporting.

I installed the agent for 7.1 SP2 and noticed it threw errors for machines with a 6.9 agent.  I tried uninstalling the 6.9 agent then installing 7.1, works fine, but my DS can't work on 6.9 without the 6.9 agent.

My 6.9 server is running IE8.