Video Screencast Help

Altiris DS 6.9 SP5 and Mac 10.8

Created: 08 Apr 2013 • Updated: 10 Apr 2013 | 4 comments

We're about to rollout new Macs running Mac OS X 10.8 but I can't get these Macs to connect to the server which runs DS 6.9 SP5 Build 517 (MR2). Older Macs running 10.5 - 10.7 work fine.

Note, we only use Altiris to collect inventory information. Deployment of Macs is handled by Apple software.

All Macs version have 'altiris-adlagent-2.6-92' installed but we get the following error in the client log with 10.8 Macs:-

[221 2013-04-06 17:28:08.245544 c8bcc89badf2 adl_session] Debug: Error:Operation timed out, connecting socket 3 to host at x.1x.x.x 402 ...
[221 2013-04-06 17:28:13.246287 c8bcc89badf2 adl_session] Warning: Error unable to connect to server
[221 2013-04-06 17:28:13.246516 c8bcc89badf2 adl_session] Debug: Error in ../common/tcp.c: Unable to set socket option to linger the address! Error: Invalid argument[221 2013-04-06 17:28:13.246575 c8bcc89badf2 adl_session] Debug: Can't set socket option:
[221 2013-04-06 17:28:13.246632 c8bcc89badf2 adl_session] Debug: -1 = Close( 3 )
[221 2013-04-06 17:28:18.247301 c8bcc89badf2 adl_session] Debug: Open socket for: x.x.x.x 402 ...
[221 2013-04-06 17:28:18.247527 c8bcc89badf2 adl_session] Debug: Connecting to host: x.x.x.x 402 ...

How do I get this to work? Is a new agent available? Do I need to update Altiris?

 

Operating Systems:

Comments 4 CommentsJump to latest comment

symdon's picture

Deployment solution 6.9 SP5 MR2 (build 517) supports MAC 10.7 OS only . Please find attached release notes for SP5 MR2 release.

For more information on MAC 10.8 support please contact Symantec support team.

 

AttachmentSize
Altiris™ Deployment Solution 6.9 SP5 MR2 from Symantec Release Notes.pdf 268.77 KB
Adrian Cooke's picture

I posted this discussion because of the lack of information from Symantec about Mac 10.8 and Altiris DS 6.9.

To add to what I originally asked, when will Altiris DS 6.9 support Mac 10.8?

 

Eric_Olsen's picture

Talking with the product manager, it sounds like Mac support past 10.7 will be in DS 7.x. If you want it in DS 6.9 you'll need to contact him and let him know. I sent him a link to this thread too.

Mr.Mik's picture

In our enviorment we use DS 6.9 SP4 and we manage MAC OSX 10.8.x with agent 2.6-92 (that comes with SP5).

We do not have any major issue.

The only case we opened with the support line is about the impossibility for 2.6-92 to recognize internal disk greater than 1 TB, they are actually reported in MB (e.g. 2 TB hard disk is reported as 2 MB).

This carries a failure for our job conditions that check for free space before installing a softwware.

 

Anyway, I know Symantec is working on SP6 that should be released this year.

Regarding your specific issue, i don't think is something with the agent but, probably on your system settings/configuration. Did you try to analyze traffic on a machine, to understand which communication and on what port is failing?

 

Regards,

Mr.Mik