Video Screencast Help

Altiris NS Server not communicating with database that is hosted on another server

Created: 18 Apr 2013 • Updated: 03 May 2013 | 6 comments
This issue has been solved. See solution.

Hello All,

I am having some problems with my helpdesk solution 6.0 SP3.  Yesterday I had accidentally powered down the powervault that was hosting the database and since then after booting it back up and reconnecting it back to our server that hosts it the NS server does not want to pick back up on the database.  It gives us the initial setup screen as if we wanted to create a whole new database.  I tried everything that it said to try and re-connect with the database but it refuses to go out and look for the information needed.  I wondered if someone could lend me some advice on what steps I can take to see if I can re-establish a connection back to the database.  I appreciate anyones time in looking at this message and giving any helpful response.

Operating Systems:

Comments 6 CommentsJump to latest comment

andykn101's picture

Run SQL Server Management Studio on a machine remote to the SQL Server and see if it can be connected to. Try it in the context of the Altiris Service Account ("App Identity").

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

hawkster78's picture

I ran the SQL Server Management Studio from another remote server and it was able to connect to the Altiris Database just fine using the SQL credentials I supplied.  I can see all the databases for altiris when I expand the Databases section.  Thank you for your time in replying!

The Gaffer's picture

Have you tried simply restarting the Altiris Service on the NS6 Server?

Rob Moore's picture

There is a regsitry entry that defines the servername and port the NS server uses to connect. Make sure the SQL server name and port are correct there.

Also, are you using a non-standard SQL port? try to Telnet from the NS server to the SQL server on the proper port to make sure you can connect to the DB.


David_Falcon's picture

Depending on what was going on, there may be a risk of corruption within the database.  It may be beneficial restore to the last known good (+transaction restores) and see if that helps. 

Once complete, I would try to to restart the NS and see if it picks up.  If not, you may have to run through the configuration and select the existing database option.

hawkster78's picture

Thank you for all the replies.  Sorry I should have closed this out sooner.  We decided that since our version was way out of date we implimented Spiceworks as our helpdesk solution.  Again thank you for your time and replies.