Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Altiris packages with long/dense paths cannot be uploaded

Created: 19 Mar 2014 • Updated: 29 Apr 2014 | 12 comments
This issue has been solved. See solution.

We are working on importing software packages into Altiris to make available for distribution.  Some of these applications are Engineering applications and have very dense (long or deep) folder paths.  Due to the fact that the Altiris file locations (\\servername\share\guid...) are very deep as well, we are unable to upload these packages into Altiris and make them available.  We have even specified a UNC location as an alternate location, but the path is still too long.  I am wondering if anyone else has experienced this issue and has found a workaround.  These applications are very common, such as Catia, Hyperworks, etc.

I understand the character limitation is a Windows limitation, but I would hope we're not the only ones who have experienced this issue and also hope someone can help shed some light on a workaround for us.

I would appreciate any help or guidance anyone can provide with this strange situation!

Thanks!

Operating Systems:

Comments 12 CommentsJump to latest comment

SK's picture

One way round this would be to make the dense apllication less dense, so that they can be imported into the SW Library.

Another way would be not use the SW Library for these types of packages, and instead place them in the root of a drive that the SMP has access to, and use the local to NS source option.

Another option would be to make them available to the SMP via a URL or UNC file store as their source, again not using the SW Library.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Dmitri Dragunov's picture

Hi,

If you use UNC or URL as package source this will not resolve the problem completely, because path to the share can be more deeper that in windows ("\\sharename\folder name" is more deeper than "c:\folder name"), or if path for package on NS is ok, you will have problem on agent, as path will be deep ("C:\program files\altiris ..."). You should specify the "Location on destination computer" advanced setting for Managed Delivery Policy or Quick Delivery task, or use "Run from the server " option.

Regards,
Dmitri

jms97's picture

Thanks Dimitri.  The problem becomes how do I upload the package into Altiris so that it replicates to all other site servers as required when the package is "requested" by a client?  Maybe this is simpler than I am making it, but I am not sure where this option you are referring to is located.  At this point, we cannot even upload the package into altiris to create a deliverable package.

Thanks!

jms97's picture

Thanks SK as well.  Sorry I didn't see your comment until I had already responded to Dimitri.

We have already discussed the option about making the packages less dense, but altering may lead to the inability to successfully install.

Where can I find this "local to NS" source option?

We have tried the UNC and or URL option and the path is still too dense.

Am I thinking about this the wrong way?  Would we NOT do an import of the software in  the traditional sense?  Is this where I am going wrong?

Thanks again.

Dmitri Dragunov's picture

Hi jms97,

How you deliver the software with deep path on clients?

If you have problems with download package on Site Server (package server), please define the package destination location on package servers:

  1. Go to Manage -> Software -> Software Releases
  2. Select software with deep path -> double click on it
  3. Go to Package tab
  4. Select package and click edit
  5. go to Package Server tab
  6. check Package Destination Location on package servers (leave blank for default) checkbox
  7. specify some not deep path (like C:\packages)

Regards,
Dmitri

jms97's picture

In many cases, the application is not in software releases...how do we handle that?

SK's picture

Once you have added the application into the sw caralog it should be listed as a sw release unless it is an update, etc.

Are you saying that after importing you cannot find it?

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

jms97's picture

We cannot import at all because the vendor's installation file structure is too deep/dense to do so.

Dmitri Dragunov's picture

Did you tried to put the software into "C:\folder" on Notification Server and during Import wizard on the first page select Source: "Access package from directory on the Notofication Server" and in Location browse the "C:\folder"?

Regards,
Dmitri

jms97's picture

This was resolved by doing an Import and not an Add within the console.  Once the Admin tried an Import vs. the method he was used to doing as an "Add", it worked.

SOLUTION
burndtjammer's picture

Despite this being resolved I would suggest the following:

Use 7-zip to make a .7z file of the entire directory and then when pushing it out use an install bat with a line similar to :

7zr.exe e Source.7z -y (you may have to play with the arguments)

7zr.exe would need to be a file included in your package.  I use this method for very large packages that I want to really condense the size of.