Video Screencast Help

Altiris Recovery Server -- Installation operation failed.

Created: 05 Jan 2013 • Updated: 04 Oct 2013 | 10 comments
This issue has been solved. See solution.

Guys,

Getting below message while executing RS 6.2 SP4 setup file, "Altiris Recovery Server -- Error 25001. Configuration of SQL database components failed. Setup cannot continue.", any suggestion please to overcome this.

 

Discussion Filed Under:

Comments 10 CommentsJump to latest comment

Ashish-Sharma's picture

HI,

Check this very old artical may be some help

Error 25001. Configuration of SQL Database components failed. Setup cannot continue' during the Recovery Solution installation.

 

Article:TECH11742  |  Created: 2006-01-09  |  Updated: 2006-01-09  |  Article URL http://www.symantec.com/docs/TECH11742

 

Thanks In Advance

Ashish Sharma

 

 

KSchroeder's picture

Is your database running on SQL Server (or MSDE) 2000 or SQL Server 2005?  2005 is required for SP4 as it is, to some degree, a back-ported RS 7.0.  See here:

http://www.symantec.com/docs/TECH155383

http://www.symantec.com/docs/DOC3495 (RS 6.2 SP4 Release Notes)

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

KSchroeder's picture

I would also have your DBAs (or yourself) check the error log on SQL server, and the Application logs on both the RS server and SQL server.  In addition, you can look at the AeXCRSS.log (err, I think that's the name) on the RS server, it should have more details about what failed.  Does the NS Applicatoin Identity/service account and AeXRSDatabaseUser local SQL account have full control (DBO) permissions to the RS database?

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

Ambesh_444's picture

Hi,

If you got your answer then please let me know, Even i need help regarding this issue.

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

mmaryan's picture

I'm seeing this same issue as well.  Does anyone have a resolution for this?

mmaryan's picture

I got this to finally re-install by removing all traces of ARS on the target server, including the registry (search for RSSServerAgent).  Also, remove all previous ODBC connections related to ARS.  Finally, remove the specific entry for the target server in the RS_Servers table on the Notification Server database.

kmccann's picture

I encountered this error when installing RS Server Agent 7.1.  It was failing on creating ODBC.  I was able to run it without issue by logging in via RDP with "Console Mode".

Mike Pikkov's picture

This often happens when you install the RS Server manually by pulling the package from the NS Server. The best workaround is to install RS Server using PUSH way (by policy, via Altiris Agent).

SOLUTION