Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Altiris service will not start

Created: 25 Sep 2013 | 9 comments

Hi:

I am running cms 7.1 and after a power failure and server crash the altiris service will not run.  The error is "Windows could not start the Altiris service on local computer. Error 1067: The process terminated unexpectedly."

The  console will not work and I don't have the option to do a repair from sim(It says to reconfigure but that fails).  Any solution?  Or is there a way to do a repair manually or re-install?

Any assistance would be much appreciated.

Thanks

Operating Systems:

Comments 9 CommentsJump to latest comment

andykn101's picture

You can repair manually by finding the msi files in %programfiles%\altiris\Symantec Installation manager\Installs\altiris

First check for the coresettings.config file in c:\programdata\Symantec\SMP\settings, a crash can cause it not to close properly or be wiped to zero bytes. If you're lucky there'll be a backup copy there or search for one.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Gus k's picture

Unfortunetly, the coresettings.config file is corrupted(empty) as is the backup. Will manualy re-installing repair the file?(coresettings.config).

Secondly which file would it be to re-install to fix the "altiris service"?  I am assumming it is "altiris_ns_7_1_sp2_x64.msi"  is this correct. 

Thanks for the assistance.

andykn101's picture

I'm afraid I'm not sure, I've always had a backup.

You'll have to run the msi from a command line with the msiexec parameter (in capitals) SKIPAIM=1.

You could try running msiexec /a and see if you can extract the files and if there's a coresettings.config file in there.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Gavin Sanish's picture

-Uninstall the Altiris Agent using the Command Prompt'

"C:\Program Files\Altiris\Altiris Agent\AeXAgentUtil.exe" /clean

-Change the Registry Value

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\CommonFilesDir

E:\Program Files\Common Files (to) C:\Program files\Common files

-Once again Reinstall the Agent.

--

 

...

G. Gavin Sanish

T : +91 9884877206
&a
andykn101's picture

Not sure that'll help, it's the Altiris Service that won't start, probably because of a corrupt coresettings.config file.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Gus k's picture

That is what I though. Is there a way to repair the file. 

andykn101's picture

Have you tried my suggestion of running msiexec /a on the msi? Do you not have any backups of the server you could get it from?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Gavin Sanish's picture

Hi Gus k,

DId you try changing  the Registry Value, if it shows a different location

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\CommonFilesDir

E:\Program Files\Common Files

(to)

C:\Program files\Common files

If it happens to be a diff location try uninstalling the agent through command prompt and reinstall it.

--

 

...

G. Gavin Sanish

T : +91 9884877206
&a
Gus k's picture

Got it resolved.  It was a corrupt "coresettings.config" file and I didn't have a good backup. 

As NS was on a VM I cloned it and uninstalled and reinsalled SMP and it created another good "coresettings.config" file.  Then it was just a matter replacing the file to the production server.  Still testing to see that everything works well.

Thanks for the responses guys. Much appreciated.