Video Screencast Help

Another Question on privileges and permissions

Created: 21 Dec 2012 | 4 comments

Hey folks,

NS 7.1

I building a custom role based on the Tier 2 role.  I've created a new folder under Jobs and Tasks > System Jobs and Tasks > Software, called "SysAdmin".  I do not want this custom role to have any any access to this folder or have the ability to run any of the jobs inside this directory.

When I log on using my custom role, and go to Manage > Jobs and Tasks > System Jobs and Tasks > Software, I cannot see the directory, that's GOOD!

However, if I got Manage > Computers, right click on a computer > Schedule Task > Select Job or Task, I can navigate to this "SysAdmin" directory and schedule a task.

How can I remove this permission?

Thanks!

gesturgis

 

 

Comments 4 CommentsJump to latest comment

gesturgis's picture

Just wanted to bump this back up to the top after the holidays.  Happy new year to all.

CFarrell's picture

As the admin, what do you see when you  go to Manage > Jobs and Tasks > System Jobs and Tasks > Software, right click on SysAdmin, select security, click on the Advanced button, and seledting the role you created? Unselecting all permissions help?

gesturgis's picture

Thanks CFarrell, unfortunately, that does not seem be working.  The only permissions that are checked there are "Report Permissions", Run Reports and Save Reports.  I've tried to uncheck those and save, but when I go back in to the same place to look again, they are still checked.  I'm not sure if this is the problem or not, but I am not able to make that change.

Triinu Gross's picture

Try the following:

  1. In the Security Role Manager, make sure that in the Role drop-down list the correct role is selected and in the View drop-down list the Tasks is selected.
  2. In the left pane, expand the folders and select the created SysAdmin folder.
  3. In the right pane, click Advanced.
  4. In the Permissions for: SysAdmin dialog box, uncheck Inherit the permission entries from parent object that apply to child objects, and then click Save changes.
  5. In the Inherited Permissions Behaviour dialog box, click Remove.
  6. Close the Permissions for: SysAdmin dialog box.
  7. In the Security Role Manager, in the right pane, click Save changes.

If your issue has been addressed, please use the "Mark as Solution" link for the relevant thread.