Video Screencast Help

any way to confirm a tape is bad and how to retrieve partial data?

Created: 21 Nov 2012 • Updated: 29 Nov 2012 | 4 comments
This issue has been solved. See solution.

Hi,

NetBackup 7.01 on solaris 10

I have trouble restoring data from a tape. It keeps complaining about 

cannot open ndmp device nrst2a, error code 16 (NDMP_NO_DEVICE_ERR)

I was able to use robtest to move the tape in and out of the drive. So I suspect it's the tape itself having problems. I have two questions:

1. Is there any way to confirm a tape is indeed bad?

2. If it's bad, is there a way to retrive partial data from the tape?

 

Thank you!

Comments 4 CommentsJump to latest comment

Joseph_TKLee's picture

1. You can test it on OS level using dd command
# dd if=tape_device of=/dev/null bs=1024k
2. From my experience, it wouldn't be possible.

I would suggest try it again after cleaning the tape drive.

Hope it helps.

Yasuhisa Ishikawa's picture

NDMP host(NetApp?) says there are no such tape device named nrst2a or the filer can not open nrst2a. It is not media problem.

First thing you have to do is to check connectivity of tape drives. Run "sysconfig -t" on the filer and check if nrst2a is present. Also check from NetBackup by running "tpautoconf -probe filer_name".

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
Nicolai's picture

Check phycial versus logical location of tape drives.

If you think first tape drive is lower one in the robot , but the filer think it's the upper you will see same error message.I don't think you have to worry about bad media for now.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.