Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

AOFO initialization failure

Created: 26 Feb 2014 • Updated: 04 Mar 2014 | 11 comments
This issue has been solved. See solution.

Kind of a two part question/issue

I did some research on this issue and not seeing much that will help.

So first off can someone explain to me in fairly lamen terms what AOFO is required for if anything?

I have a customer with a single server using backup exec. 2010.

One of my favorite things in this world of IT is a backup that had been working fine for a long time and now doesn't.

I am going to inculde a screen shot of the start of the error.

This is the first time I have worked on this client and since it is a small one server company can I just shut off AOFO and see if it still backs up ok?

It is not needed for Exchange or SQL is it?

I am going to probably start with a manual backup later today to see if that works since I have seen that suggested and if it does maybe clean up the DB?

And side note I tried to run live update and it ran for 15+ min. and never came up and told me if it had updates.   So I have cancelled that and will try it again later also.

Thanks

Mike

 

 

Operating Systems:

Comments 11 CommentsJump to latest comment

lmosla's picture

Hello,

A reboot of the server should clear this error.

and an explanation of AOFO http://www.symantec.com/docs/HOWTO24184

I strongly recommend upgrading to Backup Exec 2010R3 and then running live updates to install the most recent service pack SP4

Note: prior to the upgrade stop the SQL server BKUPEXEC service and make a copy of DATA and CATALOGS folders  after the installation push the remote agent to the remote server.

mli7777's picture

Well I tried  the Microsoft 50%+ fix of reboot last night.   :)

That did not fix the issue.

Running live update should give me the 2010R3 and SP's should it not??

I have not tried to run the live update again yet but will here in a while.

I have added a screen shot of the help about so you can see what that says the version is.

Thanks for the help.

Mike

 

 

YHVersion.PNG
lmosla's picture

This is the base Backup Exec 2010 version. The upgrade between revisions cannot be done through Live Updates.

The current version of Backup Exec 2010 R3 with many updates and fixes can be installed from the link located here http://www.symantec.com/docs/TECH66724  under BE 2010 R3 Install:  

The upgrade between revisions cannot be done through live updates.

After BE 2010 R3 is installed the most recent service pack can be installed from Live Updates.

SOLUTION
mli7777's picture

Ok a new iinteresting fact.

A partner in crime here at work had worked on this server back on the exact day the backups quit working.

He moved a lot of stuff out of a windows.old folder to a different drive to free up some space.

I ran the manual backup last night and got the same error.

So today I recreated the daily job and going to see if that helps?

Think that is a good idea ?

Still going to try and schedule time to upgrade 2010 to SP3 but want to see if this helps.

Mike

lmosla's picture

Mike,

yes recreating the job sounds like a good plan.  Keep us posted

mli7777's picture

Well it got frther and a new error ?

When it works it is about 147 gig.   It has been failing with less the 40 gig the last few.

Today it is at 43 gig and stuck at a status of snapshot processing??

Going to see if I can get some server time this weekend and put on the patches.

Mike

 

mli7777's picture

Did a reset of the services via the GUI and it was successful.

Was going to make a new weekly backup job to run tonight to see what that would do.

It is still stuck making the snapshot I think.

I do a vssadmin list writers and it just stays at the line ...  these may be delayed if a shadow copy is being prepared ..

It has been there for over 10 min.

I have seen that be slow before but always finish.

So have access this weekennd.

Going to reboot patch and see what happens then.

Mike

 

lmosla's picture

also take a look in Windows event logs for more possible troubleshooting help along with this document for what might be happening

http://www.symantec.com/docs/TECH87439 

mli7777's picture

Well I think it has got better.

The backups did not have a bunch of AOFO errors.  

The weekend full did have an error not backing up a hidden directory within that windows.old directory under something like windows/sysvol/sysvol/never_delete ??  

I go look at the server and the guy who moved most of that folder did not move that.

It probably wouldn't let him?

So it appears to still be there so not sure why it says it can't back it up?

So I have unchecked that to see again if I can remove it from the backup and see if it works better.

This will be during the daily backups not the full weekend.

But the updates seemed to help.

Mike

CraigV's picture

...a simple work-around, if the backups keep failing on the Windows.old directory, is to put in an exclusion for this particular directory. It wouldn't be needed for any restore purposes.

Also, if you use Windows Server 2003, there is a VSS Rollup Patch which can also fix VSS-related issues. Just never reregister the VSS *.dlls on Windows Server 2008 and above as it can mess things up.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

mli7777's picture

Well the daily went well.

So I think we are good.

I have had issues sometimes with excluding directories sometimes but this one seemed to work ok.

I am going to be keeping an eye on it through the next weekend and see how it goes.

Thanks for the help.

Will mark the patchup as the fix.

Mike