Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

App Center Android agent installation fails on devices

Created: 19 Jun 2013 • Updated: 20 Jun 2013 | 6 comments

I tried to install App center android agent on Android smart phone,

Downloaded the app center agent.apk but fails the installation on the phone, its gives error as "Application installation failed."

Its On premise app center server.

 

Thank you

Operating Systems:

Comments 6 CommentsJump to latest comment

Andrew_C's picture

Hello,

Where did you obtain this .apk? One can download the Android App Center App (ACA) from the console under the "Downloads" page, and the file will be called "app_dist_app.apk". The more traditional method of installing the ACA, is to access the App Center server's URL (https://servername.domain.com) from the device, which will redirect to the appropriate device OS download page.

Please provide more detail around the method you are using, the make/model of the Android device in question, and the Android version this device is running. Also, let me know if it is reproducible on any other device.

Regards,

Andrew

 

joe.zeles's picture

Are you allowing the installation of apps from unknown sources?

Joe Zeles - Sr. Systems Engineer

Intuitive Technology Group - Symantec Platinum Partner

Shrikant_Solse's picture

I have on prem installatio of App center. I also tried installing "app_dist_app.apk" which i got from Download page.

But installation is failing . futher investigation gives me error like :

INSTALL_PARSE_FAILED_NO_CERTIFICATES

Please do let me know  what I am missing while installing App center?? or is any certificate error ?

 

Andrew_C's picture

Hi Shrikant,

It is difficult to say without further information and investigation, or complete device debug log. When installing App Center, you want to ensure you use a publicly trusted SSL certificate, its corresponding private key, and associated certificate bundle. The certificate bundle is comprised of the SSL certificate's intermediate CA's certificates up to the parent root CA's certificate.

Also, when installing App Center (the post-installation-script-configuration-page), ensure you are accessing the "configurator" via the publicly accessible FQDN of the server (which should match the SSL certificate's Common Name (CN) field). The "Server name" field in the configurator must be the shortname of the server. For example:

Access the configurator via proper FQDN:  http://appcenter.domain.com:8000

In the configurator, the "Server name" field should be automatically populated with the shortname: appcenter

If the FQDN of the server is: appcenter.domain.com, then the SSL certificate must have a CN value of: appcenter.domain.com

From the mobile device, you can simply access:  https://appcenter.domain.com, and it will automatically route you to the appropriate download page for our App Center App (ACA)

 

Hopefully this information helps, and is related to your issue. If you continue to experience issues, I'd recommend opening a technical support case.

 

Regards,

Andrew

Islam15's picture

Hiu Andrew_C,

when I'm trying to download the agent it show me "NOT FOUND"

error2.png

Thank you in advance.

Andrew_C's picture

Hello,

Please create a separate thread for new issues.

I am not familiar with this error, so you may need to open an Enterprise Technical Support case. You could try changing the language to English to see if it's a localization issue.

Regards,

Andrew