Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

App Center: Keys needed to sign the App are missing

Created: 06 Sep 2013 | 1 comment
novajon's picture

I created a pretty basic App policy for iOS. It worked just fine initially, then, I modified some policy settings and tried to redistribute and now I get the message seen in the attached screen shot. I checked the /var/log/nukona/appstore.log and it has this error message

timestamp=2013-09-06 09:39:48.156,logname=aclog,level=ERROR,module=bundle,function=get_profile_with_checks,line=1014,tenant=appcenter,username=ncadmin,sessionid=############,url=/appstore/webapi2/app/save,msgid=APP_BUNDLE_CODESIGN_KEY_404,msg=No Codesigning Keys found
 
Note: I removed sessinid value and replaced with ##
 
Any ideas what might cause this?
 
Thanks in advance
Operating Systems:

Comments 1 CommentJump to latest comment

Andrew_C's picture

Hello,

Did the 'iNova' app originally have a policy applied when you first distributed it?

The most likely cause is that code-signing certificate (or "distribution certificate"), used to compile and sign the app, is not yet uploaded to App Center. When wrapping an iOS app, we're basically recompiling said app with our wrap code included. In order to do this, we must have the same code-signing cert that the app was originally compiled and signed with in order to recompile it with our wrap code. The app's corresponding code-signing certificate should be uploaded in the App Center console under: Settings > [Certificates] Apple/iOS Certificate > Code-Signing Certificates.

If it appears this certificate is already uploaded, it would be best to review the source code of the app and compare it to the uploaded certificate information, like the serial number.

If this all looks good, I would review the ioswrapdaemon.log file for additional information

 

Regards,

Andrew