Video Screencast Help

Apple Quicktime

Created: 06 Mar 2012 | 3 comments
Randy F's picture

I have a client that wants to virtualize Apple Quicktime.  Anyone that packages quicktime also knows that for the past year of so you also have to install Apple Application Support.

In my attempts to create a Layer for Quicktime I have had a problem after saving the file then launching it on a new machine.   When I do launch it I get an error stating that Apple Application Support needs to be installed.  If I run it right after creating the layer it works fine.  Even after Exporting/Deleting then importing the new file.  However... once I refresh the machine and then do an import (same machine... just reverted back to previous snapshot) I receive the error.

To me it seems that something is being installed outside of the layer.  I am creating the layer by selecting cmd.exe from the SWV Admin tool then running all of the installations from the (Apple Application Support then Quicktime) resulting DOS box/prompt.  Just hoping that someone else may have run into this and have the answer.

 

Thanks,

Randy

Comments 3 CommentsJump to latest comment

EdT's picture

Apple software installs configuration files into the user profile. It could be that your layer creation is somehow missing this content.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Randy F's picture

Are you referring to the QuickTime.qtp, QTPlayerSession.xml and com.apple.QuickTime.plist?

These files are in the package... but I do know that normally... if they are not there... Quicktime will generate these files automatically.

Colin Bragg's picture

There are a few things you can try:

1) Ensure that you capture your layer using the global capture method, in case something spawned off is not being captured.  This may involve some cleaning up of the package afterwards though because this will capture all changes on the machine

2) Remove all exclusions to see if something is not getting captured

3) Ensure that you mark the option "keep File changes in layer" in case an external process is making the changes.

 

Only one of these is likely to solve your issue, so experiment with them