Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

appliance media server cannot join to master

Created: 29 May 2013 • Updated: 04 Jun 2013 | 5 comments
This issue has been solved. See solution.

I tried to configure the 5220 appliance as a media server and join to the standalone master server but with no luck.

The setup wizard from appliance WebGUI went through fine without error, but after I logout and log back in, the setup wizard appears again. From CLISH commandline, it also says the appliance role has not been setup, and storage unit name still shows as default name 'unit_1' which I have changed during the setup, following is the output capture from the setup wizard and the output of storage>show. 

 

Checking the pre-requisites .....
 
Validating master server name 'masterserver1'
Ping check               ........ :[OK]
Name lookup check        ........ :[OK]
Firewall/Port check      ........ :[OK]
Restarting NetBackup services ... :[OK]
Master access check       ....... :[OK]
Checking master type      ....... :[OK]
Version compatibility check ..... :[OK]
 
*** Using masterserver1 as master server
 
---------------------------------------------------------------
INFO: Adding the following servers to the NetBackup configuration
SERVER=masterserver1
---------------------------------------------------------------
 
Stopping NetBackup processes
Performing Deduplication Engine cleanup
Configuring media server on the appliance ...
Restarting NetBackup daemons on the local host.
Creating media server storage partitions and storage units ...
Configuring storage pool:
Checking Deduplication Licenses...
Creating storage partitions and storage units ...
Starting NetBackup processes... (2 min approx)
Creating 'Deduplication' DiskPool 'dp_disk_masterserver1' and Storage Unit 'masterserver1_puredisk'...
 
myappliance1.Storage> show
------------------------------------------------------------------------------------------------
Device                                         | Total            | Unallocated | Status
-------------------------------------------------------------------------------------------------
Appliance Operating System (sda) |   930.38 GB |        -           | In Use
Base Unit Storage (unit_1)             |   4.5429 TB |   937.84 MB | In Use
 
Base Unit Storage (unit_1)
--------------------------
Catalog      :      1 GB
Deduplication: 4.5410 TB
 
---------------------------------------------------------------------------------------------
Partition          | Total          | Available     | Used           | %Used
-----------------------------------------------------------------------------------------------
AdvancedDisk |        0 GB   |        0 GB   |        0 GB    |    0%
Deduplication |   4.5410 TB  |   4.5051 TB |   36.718 GB |     1
Unallocated   |   937.84 MB |        -           |        -          |    -

 

any help is appreciated

Operating Systems:

Comments 5 CommentsJump to latest comment

Marianne's picture

Have you added a SERVER entry on the master server for the Appliance, followed by NBU restart?

Have you verified hostname lookup to Appliance from the master? Can master resolve Appliance IP address to hostname that you've added to the SERVER list?

Do you have NBU Enterprise Server license on the master?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

jaite275's picture

I did add the appliance as additional server from the master admin console, but did not restart the NBU on the master.

the appliance hostname does not registered to DNS yet but I added the appliance in the master server (a Linxu server) /etc/hosts file. how can I confirm if master can resolve Appliance IP? I tried 'host <appliance_IP> but could not resolve.

we do have permanent NBU license, the master has already had several media connected to it.

Can it be firewall issue? from the Appliance, I can telnet to master on port 1556, 13724 and 13720, but not from master to the appliance.

Also why there is 937.84 MB unallocated space?

Marianne's picture

To confirm reverse lookup, run 'bpclntcmd -ip (appliance-IP)' on the master.

You problem could be with firewall, but remember that you won't be able to connect until processes are started on Appliance.

Please create admin log folder and retry Appliance config (provided you have restarted NBU on master).

Let us know how it goes. If it fails again, please post admin log on master server as File attachment.

The unallocated space is a separate issue - please start a new discussion in NetBackup Appliance forum.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

jaite275's picture

the reverse lookup is fine, all required firewall are opened. I rerun the setup wizard (but forgot to enable the admin log), the setup completed successfully without error.

from adminstration console, I can see the appliance comes up as Media server with all the server info. however, re-log back in to appliance admin page, it is still a setup wizard page. from CLISH menu

Appliance> status
====================================================

Appliance Version is 2.5.
Appliance is configured in factory installed state.
All disk volumes below water marks

it is very strange, any idea?

jaite275's picture

Problem solved. Symantec support suggested to manual edit the bp.conf file by changing appliance role to media server, which has corrected the issue.

SOLUTION